• ZOJ Problem Set–1760 Doubles


    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

    1 4 3 2 9 7 18 22
    your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

    Input

    The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

    Output

    The output will consist of one line per input list, containing a count of the items that are double some other item.

    Sample Input

    1 4 3 2 9 7 18 22 0
    2 4 8 10 0
    7 5 11 13 1 3 0
    -1


    Sample Output

    3
    2
    0


    Source: Mid-Central USA 2003

    #include<iostream>
    
    #include<set>
    
    using namespace std;
    
    int main(void)
    
    {
    
      while(true)
    
      {
    
        set<int> s;
    
        int n, doubles = 0;
    
        while(cin>>n && n)
    
        {
    
          if(n == -1)
    
            return 0;
    
          s.insert(n);
    
          if(s.find(2*n) != s.end())
    
            doubles++;
    
          if(n%2 == 0 && s.find(n/2) != s.end())
    
            doubles++;
    
        }
    
        cout<<doubles<<endl;
    
      }
    
      return 0;
    
    }
  • 相关阅读:
    凤凰架构-读书笔记
    《团队协作的五大障碍》笔记
    MongoDB基本操作命令一
    NBI可视化集成clickhouse,实现百亿级数据分析能力
    AI文本与图像数据集荟萃
    gitLab内网部署
    git管理子模块
    git基础使用
    linux内核数据结构之链表-再实现
    win10下安装linux子系统
  • 原文地址:https://www.cnblogs.com/malloc/p/2482831.html
Copyright © 2020-2023  润新知