• ZOJ Problem Set–1251 Box of Bricks


    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

    Input
    The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.
    The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

    The input is terminated by a set starting with n = 0. This set should not be processed.

    Output
    For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.
    Output a blank line after each set.

    Sample Input
    6
    5 2 4 1 7 5
    0

    Sample Output
    Set #1
    The minimum number of moves is 5.


    Source: Southwestern Europe 1997
    #include<iostream>
    
    #include<vector>
    
    using namespace std;
    
    int main()
    
    {
    
      int n, avg, i = 1, sum = 0, steps = 0;
    
      while(cin>>n && n)
    
      {
    
        steps = 0;
    
        sum = 0;
    
        vector<int> v;
    
        int hi;
    
        for(int j = 0; j < n;j++)
    
        {
    
          cin>>hi;
    
          v.push_back(hi);
    
          sum += hi;
    
        }
    
        avg = sum / v.size();
    
        for(int j = 0; j < v.size(); j++)
    
        {
    
          if(v[j] - avg > 0)
    
            steps += v[j] - avg;
    
        }
    
        cout<<"Set #"<<i<<endl;
    
        cout<<"The minimum number of moves is "<<steps<<"."<<endl<<endl;
    
        i++;
    
      }
    
    }
  • 相关阅读:
    [转]在Ubuntu 下安装Redis 并使用init 脚本启动
    [资源]PHP使用消息队列
    [转]reids客户端 redis-cli用法
    [转]redis.conf的配置解析
    【转】微信公共号开发,提示“该公众号暂时无法提供服务,请稍后再试”,如何解决?
    [转]php 解决json_encode中文UNICODE转码问题
    [资料]Keychain 获取设备唯一
    [转]PHP 获取服务器详细信息代码
    crontab任务取消发送邮件
    [转]php返回json数据中文显示的问题
  • 原文地址:https://www.cnblogs.com/malloc/p/2419583.html
Copyright © 2020-2023  润新知