Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:
Type | Metric | English | equivalent |
Weight | 1.000 | kilograms | 2.2046 pounds |
Weight | 0.4536 | kilograms | 1.0000 pound |
Volume | 1.0000 | liter | 0.2642 gallons |
Volume | 3.7854 | liters | 1.0000 gallon |
Input
The first line of input contains a single integer N, (1 <= N <= 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters and gallons respectively.
Output
For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.
Sample Input
5
1 kg
2 l
7 lb
3.5 g
0 l
Sample Output
1 2.2046 lb
2 0.5284 g
3 3.1752 kg
4 13.2489 l
5 0.0000 g
Source: Greater New York Region 2007
SOURCE CODE:
#include<iostream>
#include<iomanip>
#include<string>
using namespace std;
int main()
{
int cases;cin>>cases;
for(int i = 1; i <= cases; i++)
{
double num;cin>>num;
string s;cin>>s;
cout<<i << " "<<fixed<<setprecision(4);
if(s == "kg")
{
cout<<2.2046 * num<<" lb"<<endl;
}
else if( s == "lb")
{
cout<<0.4536 * num<<" kg"<<endl;
}
else if(s == "l")
{
cout<<0.2642 * num<<" g"<<endl;
}
else if(s == "g")
{
cout<<3.7854 * num<<" l"<<endl;
}
}
return 0;
}
这是一道考察输出格式控制的题目,利用标准库的iomanip很容易就做到了输出保留四位小数的要求。