• POJ 2051 Argus


    Argus
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 8782   Accepted: 3985

    Description

    A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following. 
    Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes." 
    Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

    We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency. 

    For the Argus, we use the following instruction to register a query: 
    Register Q_num Period

    Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds. 

    Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num. 

    Input

    The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#". 

    The second part is your task. This part contains only one line, which is one positive integer K (<= 10000). 

    Output

    You should output the Q_num of the first K queries to return the results, one number per line.

    Sample Input

    Register 2004 200
    Register 2005 300
    #
    5
    

    Sample Output

    2004
    2005
    2004
    2004
    2005
    题目大意:输入一串用户的命令,id,周期,没过一个周期输出一次id,输入以“#”结束,最后一行输入一个整数n,表示打印n个用户id。
    解题方法:堆排序,用最小堆,每次将时间值最小的放到堆顶,然后输出,加上时间周期之后在进行堆调制,重复n次即可。
    #include <stdio.h>
    #include <iostream>
    #include <string.h>
    using namespace std;
    
    typedef struct 
    {
        int time;
        int period;
        int id;
    }Node;
    
    Node user[10000];
    
    void sift(int low, int high)
    {
        int i = low;
        int j = 2 * i;
        Node temp = user[i];
        while(j <= high)
        {
            if (j < high && (user[j].time > user[j + 1].time || (user[j].time == user[j + 1].time && user[j].id > user[j + 1].id)))
            {
                j++;
            }
            if (temp.time > user[j].time || (temp.time == user[j].time && temp.id > user[j].id))
            {
                user[i].id = user[j].id;
                user[i].period = user[j].period;
                user[i].time = user[j].time;
                i = j;
                j = i * 2;
            }
            else
            {
                break;
            }
        }
        user[i] = temp;
    }
    
    int main()
    {
        char cmd[50];
        int id, period, n;
        int nCount = 0;
        while(true)
        {
            cin>>cmd;
            if (strcmp(cmd, "#") == 0)
            {
                break;
            }
            cin>>id>>period;
            user[++nCount].id = id;
            user[nCount].period = period;
            user[nCount].time = period;
        }
        cin>>n;
        while(n--)
        {
            for (int i = nCount / 2; i >= 1; i--)
            {
                sift(i, nCount);
            }
            user[1].time += user[1].period;
            cout<<user[1].id<<endl;
        }
        return 0;
    }
  • 相关阅读:
    oc调用rest api
    EF Attach时已存在的处理方式
    设置XtraForm标题居中
    读取DBF文件数据
    GP 环境参数名称列表
    MapWinGIS.ocx 注册
    ArcEngine :The XY domain on the spatial reference is not set or invalid错误
    批量修改sql server 2008的架构
    net不安装Oracle11g客户端直接使用ODAC
    Ninject使用介绍
  • 原文地址:https://www.cnblogs.com/lzmfywz/p/3239388.html
Copyright © 2020-2023  润新知