• Elevator


    /*Elevator
    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input
    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

    Output
    Print the total time on a single line for each test case.

    Sample Input
    1 2
    3 2 3 1
    0
     

    Sample Output
    17
    41

    */
    #include<stdio.h>
    int main()
    {
        int test,i;
        while(~scanf("%d",&test),test!=0)
        {
            int a[110]={0};
            int sum=0;
            for(i=0;i<test;i++)
            scanf("%d",&a[i]);
            for(i=0;i<test-1;i++)//这一步推断是关键 。注意i<test-1
            {
                if(a[i+1]>a[i])
                sum+=(a[i+1]-a[i])*6;
                else
                sum+=(a[i]-a[i+1])*4;
            }
            printf("%d ",sum+a[0]*6+test*5);
        }
        return 0;
    }
           
           
       

  • 相关阅读:
    SpringBoot+mybatis的驼峰命名转换不生效
    vue3 ts遇到的问题
    阿里巴巴的Java 工程脚手架
    Mybatis获取插入值的ID
    Bootstrap的Modal与WebUploader联用的问题及办法
    Flex布局专题
    23种设计模式
    排序算法-Java实现快速排序算法
    中间件面试专题:kafka高频面试问题
    中间件面试专题:RabbitMQ高频面试问题
  • 原文地址:https://www.cnblogs.com/lytwajue/p/6943818.html
Copyright © 2020-2023  润新知