• HDU--Elevator(水题)


    Elevator

    Time Limit: 1000ms   Memory limit: 32768K  有疑问?点这里^_^

    题目描写叙述

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    输入

    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

    输出

    Print the total time on a single line for each test case.

    演示样例输入

    1 2
    3 2 3 1
    0

    演示样例输出

    17
    41
    水题。but坑了我一顿,本渣以为这电梯上到顶就会下来不在上去了呢。。

    所以一開始开数组做的WA了

    #include <iostream>
    #include <cstring>
    #include <algorithm>
    #include <stdlib.h>
    #include <vector>
    using namespace std;
    int main()
    {
      int n,i,start,x,sum;
      while(cin>>n)
      {
      	if(!n)break;
      	sum=0;start=0;
      	for(i=1;i<=n;i++)
    	{
    		cin>>x;
    		if(x>start) sum+=6*(x-start);
    		else sum+=4*(start-x);
    		sum+=5;
    		start=x;
    	}
    	cout<<sum<<endl;
      }
      return 0;
    }


  • 相关阅读:
    面试常见问题
    Servlet上传下载
    Java五大框架
    Jquery
    JavaEE
    Html学习
    JavaSE高级
    面向过程基础
    Java开发软件安装及配置
    JAVA的类加载机制和Class类
  • 原文地址:https://www.cnblogs.com/lytwajue/p/6721358.html
Copyright © 2020-2023  润新知