• luogu P1074 靶形数独


    题目描述

    小城和小华都是热爱数学的好学生,最近,他们不约而同地迷上了数独游戏,好胜的他

    们想用数独来一比高低。但普通的数独对他们来说都过于简单了,于是他们向 Z 博士请教,

    Z 博士拿出了他最近发明的“靶形数独”,作为这两个孩子比试的题目。

    靶形数独的方格同普通数独一样,在 9 格宽×9 格高的大九宫格中有 9 个 3 格宽×3 格

    高的小九宫格(用粗黑色线隔开的)。在这个大九宫格中,有一些数字是已知的,根据这些数字,利用逻辑推理,在其他的空格上填入 1 到 9 的数字。每个数字在每个小九宫格内不能

    重复出现,每个数字在每行、每列也不能重复出现。但靶形数独有一点和普通数独不同,即

    每一个方格都有一个分值,而且如同一个靶子一样,离中心越近则分值越高。(如图)

    上图具体的分值分布是:最里面一格(黄色区域)为 10 分,黄色区域外面的一圈(红

    色区域)每个格子为 9 分,再外面一圈(蓝色区域)每个格子为 8 分,蓝色区域外面一圈(棕

    色区域)每个格子为 7 分,最外面一圈(白色区域)每个格子为 6 分,如上图所示。比赛的

    要求是:每个人必须完成一个给定的数独(每个给定数独可能有不同的填法),而且要争取

    更高的总分数。而这个总分数即每个方格上的分值和完成这个数独时填在相应格上的数字

    的乘积的总和

    总分数即每个方格上的分值和完成这个数独时填在相应格上的数字

    的乘积的总和。如图,在以下的这个已经填完数字的靶形数独游戏中,总分数为 2829。游戏规定,将以总分数的高低决出胜负。

    由于求胜心切,小城找到了善于编程的你,让你帮他求出,对于给定的靶形数独,能

    够得到的最高分数。

    输入输出格式

    输入格式:

    一共 9 行。每行 9 个整数(每个数都在 0―9 的范围内),表示一个尚未填满的数独方

    格,未填的空格用“0”表示。每两个数字之间用一个空格隔开。

    输出格式:

    输出文件 sudoku.out 共 1 行。

    输出可以得到的靶形数独的最高分数。如果这个数独无解,则输出整数-1。

    输入输出样例

    输入样例#1:
    sudoku1
    7 0 0 9 0 0 0 0 1 
    1 0 0 0 0 5 9 0 0 
    0 0 0 2 0 0 0 8 0 
    0 0 5 0 2 0 0 0 3 
    0 0 0 0 0 0 6 4 8 
    4 1 3 0 0 0 0 0 0 
    0 0 7 0 0 2 0 9 0 
    2 0 1 0 6 0 8 0 4 
    0 8 0 5 0 4 0 1 2
    
    sudoku2
    0 0 0 7 0 2 4 5 3 
    9 0 0 0 0 8 0 0 0 
    7 4 0 0 0 5 0 1 0 
    1 9 5 0 8 0 0 0 0 
    0 7 0 0 0 0 0 2 5 
    0 3 0 5 7 9 1 0 8 
    0 0 0 6 0 1 0 0 0 
    0 6 0 9 0 0 0 0 1 
    0 0 0 0 0 0 0 0 6
    输出样例#1:
    sudoku1
    2829
    
    sudoku2
    2852

    说明

    【数据范围】

    40%的数据,数独中非 0 数的个数不少于 30。

    80%的数据,数独中非 0 数的个数不少于 26。

    100%的数据,数独中非 0 数的个数不少于 24。

    NOIP 2009 提高组 第四题

    40

    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <cmath>
    #include <cstring>
    #include <ctime>
    
    using namespace std;
    const int N = 11;
    
    #define Nine 9
    
    int a[N][N], answer, tim;
    bool lie[N][N], hang[N][N], ge[N][N];
    
    const int X[N * 8] = {0, 5, 4, 4, 4, 5, 6, 6, 6, 5, 3, 3, 3, 3, 3, 4, 5, 6, 7, 7, 7, 7, 7, 6, 5, 4, 
                    2, 2, 2, 2, 2, 2, 2, 3, 4, 5, 6, 7, 8, 8, 8, 8, 8, 8, 8, 7, 6, 5, 4, 3, 1, 1, 
                    1, 1, 1, 1, 1, 1, 1, 2, 3, 4, 5, 6, 7, 8, 9, 9, 9, 9, 9, 9, 9, 9, 9, 8, 7, 6, 5, 4, 3, 2, 0};
    const int Y[N * 8] = {0, 5, 4, 5, 6, 6, 6, 5, 4, 4, 3, 4, 5, 6, 7, 7, 7, 7, 7, 6, 5, 4, 3, 3, 3, 3,
                     2, 3, 4, 5, 6, 7, 8, 8, 8, 8, 8, 8, 8, 7, 6, 5, 4, 3, 2, 2, 2, 2, 2, 2, 1, 2,
                    3, 4, 5, 6, 7, 8, 9, 9, 9, 9, 9, 9, 9, 9, 9, 8, 7, 6, 5, 4, 3, 2, 1, 1, 1, 1, 1, 1, 1, 1, 0};
    
    inline int read() 
    {
        int x = 0; char c = getchar();
        while(c < '0' || c > '9') c = getchar();
        while(c >= '0' && c <= '9') x = x * 10 + c - '0', c = getchar();
        return x;
    }
    
    int calc(int x, int y) 
    {
        return (x / 3 + (x % 3 == 0 ? 0 : 1) - 1) * 3 + y / 3 + (y % 3 == 0 ? 0 : 1);
    }
    
    void print()
    {
        cout<<"~~~~~~~~~~~~~~~~~"<<endl;
        for(int i = 1; i <= Nine; i ++)
        {
            for(int j = 1; j <= Nine; j ++)
                cout<<a[i][j]<<" ";
            cout<<endl;
        }
        int ans = 0;
        int yc;
        for(int i = 1; i <= 81; i ++)
        {
            int x = X[i], y = Y[i];
            if(x == y && x <= 5)
                yc = x + 5;
            ans += a[x][y] * yc;
        }
        answer = max(answer, ans);
        return ;
    }
    
    void dfs(int tot)
    {
        tim ++;
        if(tim > 1000000)
        {
            printf("%d",answer == 0 ? -1 : answer);
            exit(0);
        }
        if(tot == 82)
        {
            print();
            return ;
        }
        int x = X[tot];
        int y = Y[tot];
        if(a[x][y])
            dfs(tot + 1);
        else
        {
            int gee = calc(x, y);
            for(int i = Nine; i >= 1; i --) 
            {
                if(!hang[x][i] && !lie[y][i] && !ge[gee][i]) 
                {
                    hang[x][i] = lie[y][i] = ge[gee][i] = 1;
                    a[x][y] = i;
                    dfs(tot + 1);
                    a[x][y] = 0;
                    hang[x][i] = lie[y][i] = ge[gee][i] = 0;
                }
            }
        }
    }
    
    int main()
    {
        //tim = clock();
        for(int i = 1; i <= Nine; i ++)
            for(int j = 1; j <= Nine; j ++)
                a[i][j] = read();
        for(int i = 1; i <= Nine; i ++)
            for(int j = 1; j <= Nine; j ++)
                if(a[i][j])
                    hang[i][a[i][j]] = 1, lie[j][a[i][j]] = 1, ge[calc(i, j)][a[i][j]] = 1;
        dfs(1);
        printf("%d", answer == 0 ? -1 : answer);
        return 0;
    }
    
    /*
    7 0 8 4 0 0 2 0 0
    2 5 0 6 8 0 0 3 9
    0 9 0 0 2 0 0 8 0
    0 0 0 0 0 0 3 9 4
    0 0 0 0 0 0 0 0 0
    9 0 0 0 0 4 0 2 0
    0 0 0 0 0 0 0 0 8
    3 0 0 0 0 0 6 7 0
    0 0 0 0 0 8 5 0 3
    2854
    */

    luogu 90, codevs A

    思路:A*搜索

    每次找出选择数字最小的点

    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <iostream>
    #include <algorithm>
    
    using namespace std;
    const int N = 10;
    
    #define Nine 9
    
    int a[N][N], Fs[N][N], Ge[N][N], Hang[N][N], Lie[N][N], bel[N][N];
    int ans = -1;
    
    void dfs()
    {
        int x = 1,y = 1,step = 10;
        for (int i = 1; i <= Nine; i++)//每次寻找出最少能填的格子 
            for (int j = 1; j <= Nine; j++)
            {
                if (!a[i][j])
                {
                    int s = 0;
                    for (int k = 1; k <= Nine; k++)    
                    if (!Ge[bel[i][j]][k] && !Hang[i][k] && !Lie[j][k])
                    s++;
                    if (s < step)
                    {
                        step = s;
                        x = i;
                        y = j;
                    }
                }
            }
        if (step == 10)//全部有数字
        {
            int k = 0;
            for (int i = 1; i <= Nine; i++)
            for (int j = 1; j <= Nine; j++)
            k += a[i][j] * Fs[i][j];
            ans = max(ans,k); 
        }
        for (int k = 1; k <= Nine; k++)
        {
            
            int gg = Ge[bel[x][y]][k];
            int hh = Hang[x][k];
            int ll = Lie[y][k];
       
        if (!Ge[bel[x][y]][k] && !Hang[x][k] && !Lie[y][k])
        {
            Ge[bel[x][y]][k] = Hang[x][k] = Lie[y][k] = 1;
            a[x][y] = k;
            dfs();
            a[x][y] = 0;
            Ge[bel[x][y]][k] = Hang[x][k] = Lie[y][k] = 0;
        } }
    }
    
    int main()
    {
        for (int i = 1; i <= Nine; i++)
            for (int j = 1; j <= Nine; j++)
            {
                scanf ("%d",&a[i][j]); 
                Fs[i][j] = 10 - max(abs(i - 5),abs(j - 5));
                    bel[i][j] =  (i - 1) / 3 * 3 + (j - 1) / 3 + 1;
                       Ge[bel[i][j]][a[i][j]] = 1;
                    Hang[i][a[i][j]] = 1;
                Lie[j][a[i][j]] = 1;
            }
        dfs();
        printf("%d",ans);
        return 0;
    }
  • 相关阅读:
    Spring bean作用域
    软件类说明文档排版建议
    fit_line_contour_xld拟合直线的五种算法的准确度比较
    .Net优秀开源(5)SqlSugar
    .NET[C#]中实现实体对象深拷贝(克隆/复制)的几种方法
    spring框架学习(14)AOP(中)
    .Net优秀开源(4)Castle.Core
    .Net优秀开源(3)Dapper
    .Net优秀开源(2)Autofac
    .Net优秀开源(1)
  • 原文地址:https://www.cnblogs.com/lyqlyq/p/7667902.html
Copyright © 2020-2023  润新知