• HDU 1405


    The Last Practice

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6245    Accepted Submission(s): 1265


    Problem Description
    Tomorrow is contest day, Are you all ready?
    We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

    Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
    what does this problem describe?
    Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.
     
    Input
    Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.
     
    Output
    For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.
     
    Sample Input
    60 12 -1
     
    Sample Output
    Case 1. 2 2 3 1 5 1 Case 2. 2 2 3 1
    Hint
    60=2^2*3^1*5^1
     
     
    一定要注意输出格式!!!!
     
    #include<stdio.h>
    #include<string.h>
    #include<math.h>
    int  prime[65536],a[65536];
    int isprime(int n)   //判断是否为素数的函数
    {   
      int i;   
      for(i=2;i<=sqrt(n);i++)    
         if(n%i==0)    
             return 0;    
         return 1;
    }
    int main()
    {   
      int count=0,i,n,num=1,maxnum;
        for(i=2;i<65536;i++)        //用素数存到prime[]数组中  
       {      
       if(isprime(i))         
        prime[count++]=i;  
       }    
    while(~scanf("%d",&n)&&n>=0)    
    {       
      if(num!=1)         
        printf(" ");   
          maxnum=0;                  //maxnum用于存储n的最大素数因子prime[]的下标     
        memset(a,0,sizeof(a));        
    for(i=0;i<count;i++)       
      {          
       if(prime[i]>n)               
      break;          
       while(n%prime[i]==0)         
        {               
                a[i]++;              
       n=n/prime[i];             
        if(i>maxnum)            
             maxnum=i;          
          }        
    }        
    printf("Case %d. ",num++);      
       for(i=0;i<maxnum;i++)          
       if(a[i]!=0)              
       printf("%d %d ",prime[i],a[i]);            
    printf("%d %d ",prime[i],a[i]);  
       }
    }
  • 相关阅读:
    java 学习帮助
    权限
    ftp mybatis
    注解
    hadoop english
    userDao
    发布订阅模式 和委托
    webservice
    rabbitMq视频教程
    blog url.txt
  • 原文地址:https://www.cnblogs.com/lxm940130740/p/hdu1405.html
Copyright © 2020-2023  润新知