• hdu1247


    Hat’s Words

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6422    Accepted Submission(s): 2399


    Problem Description
    A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
    You are to find all the hat’s words in a dictionary.
     
    Input
    Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
    Only one case.
     
    Output
    Your output should contain all the hat’s words, one per line, in alphabetical order.
     
    Sample Input
    a
    ahat
    hat
    hatword
    hziee
    word
     
    Sample Output
    ahat
    hatword
     
    思路:把每个单词分为两部分,判断两部分是否都在已经建好的字典树中
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<malloc.h>
    #define MAX 50010
    using namespace std;
    char st[MAX][105];
    struct tree
    {
        struct tree *child[26];
        int v;
    }*root;
    void init()
    {
        int i;
        root=(struct tree*)malloc(sizeof(struct tree));
        for(i=0; i<26; i++)
        {
            root->child[i]=0;
            root->v=0;
        }
        return ;
    }
    void build(char *str)
    {
        int id,i,j,len;
        len=strlen(str);
        struct tree *p=root,*q;
        for(i=0; i<len; i++)
        {
            id=str[i]-'a';
            if(p->child[id]==0)
            {
                q=(struct tree*)malloc(sizeof(struct tree));
                for(j=0; j<26; j++)
                    q->child[j]=0;
                p->child[id]=q;
                p=p->child[id];
                p->v=-1;
            }
            else
            {
                p=p->child[id];
            }
        }
        p->v=1;
        return ;
    }
    int find(char *str)
    {
        int len=strlen(str);
        int i,j,id;
        struct tree *p=root;
        for(i=0; i<len; i++)
        {
            id=str[i]-'a';
            if(p->child[id]==0)
                return -1;
            p=p->child[id];
        }
        if(p->v==1)
            return 1;
        else
            return -1;
    }
    int main()
    {
        int cnt,i,j,len;
        char a[105],b[105];
        init();
        cnt=0;
        while(scanf("%s",st[cnt])!=EOF)
        {
            build(st[cnt]);
            cnt++;
        }
        for(i=0; i<cnt; i++)
        {
            len=strlen(st[i]);
            for(j=0; j<len; j++)
            {
                memset( a,'',sizeof(a) );
                memset( b,'',sizeof(b) );
                strncpy(a,st[i],j);
                strncpy(b,st[i]+j,len-j);
                if(find(a)==1&&find(b)==1)
                {
                    printf("%s ",st[i]);
                    break;
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    [RxSwift]4.4、Operator
    [RxSwift]4.3.6、ControlProperty
    [RxSwift]4.3.5、Variable (已弃用)
    [RxSwift]4.3.0、Observable & Observer 既是可监听序列也是观察者
    [RxSwift]4.2.2、Binder
    [RxSwift]4.2.1、AnyObserver
    Java重温学习笔记,Java8新特性:接口的默认方法
    Tomcat下,MySQL连接池的配置和使用(Tomcat9,MySQL5.5)
    MyEclipse2020配置JDK1.8及Tomcat9
    Java重温学习笔记,Java7新特性
  • 原文地址:https://www.cnblogs.com/lxm940130740/p/3566465.html
Copyright © 2020-2023  润新知