Greatest Common Increasing Subsequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3365 Accepted Submission(s): 1062
Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
Output
output print L - the length of the greatest common increasing subsequence of both sequences.
Sample Input
1
5
1 4 2 5 -12
4
-12 1 2 4
Sample Output
2
#include<iostream>
#include<string.h>
using namespace std;
int a[505],b[505],f[505];
int main()
{
int T,i,n1,n2,j,k,max;
cin>>T;
while(T--)
{
cin>>n1;
for(i=1; i<=n1; i++)
cin>>a[i];
cin>>n2;
for(i=1; i<=n2; i++)
cin>>b[i];
memset(f,0,sizeof(f));
for(i=1; i<=n1; i++)
{
max=0;
for(j=1; j<=n2; j++)
{
if(a[i]>b[j]&&max<f[j])
max=f[j];
if(a[i]==b[j])
f[j]=max+1;
}
}
max=0;
for(i=1; i<=n2; i++)
if(f[i]>max)
max=f[i];
cout<<max<<endl;
if(T!=0)
cout<<endl;
}
return 0;
}
#include<string.h>
using namespace std;
int a[505],b[505],f[505];
int main()
{
int T,i,n1,n2,j,k,max;
cin>>T;
while(T--)
{
cin>>n1;
for(i=1; i<=n1; i++)
cin>>a[i];
cin>>n2;
for(i=1; i<=n2; i++)
cin>>b[i];
memset(f,0,sizeof(f));
for(i=1; i<=n1; i++)
{
max=0;
for(j=1; j<=n2; j++)
{
if(a[i]>b[j]&&max<f[j])
max=f[j];
if(a[i]==b[j])
f[j]=max+1;
}
}
max=0;
for(i=1; i<=n2; i++)
if(f[i]>max)
max=f[i];
cout<<max<<endl;
if(T!=0)
cout<<endl;
}
return 0;
}