• HUD-1708_FatMouse and Cheese


    FatMouse and Cheese

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

    Problem Description

    FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

    FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

    Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

    Input

    There are several test cases. Each test case consists of

    a line containing two integers between 1 and 100: n and k
    n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
    The input ends with a pair of -1's.

    Output

    For each test case output in a line the single integer giving the number of blocks of cheese collected.

    Sample Input

    3 1
    1 2 5
    10 11 6
    12 12 7
    -1 -1

    Sample Output

    37

    题意:给一个图,从(0,0)开始走,只能走上向左右,所去的位置上的数要大于当前位置,每到一个位置可以将这个位置的数累加到自身,问最多能取多大的数。
    题解:DP题目,记忆+DFS。注意是多组输入,(-1,-1)停止。

    #include <iostream>
    
    using namespace std;
    
    int n,dp[105][105],s[105][105],k;
    
    int Next[4][2] = {1,0,-1,0,0,-1,0,1};
    
    int juedge(int x,int y)
    {
        if(x>=0&&y>=0&&x<n&&y<n)
            return 1;
        return 0;
    }
    
    int DFS(int x,int y)
    {
        if(dp[x][y])
            return dp[x][y];
        int i,j,dx,dy,MAX;
        MAX = 0;
        for(i=1;i<=k;i++)
        {
            for(j=0;j<4;j++)
            {
                dx = x + Next[j][0] * i;
                dy = y + Next[j][1] * i;
                if(juedge(dx,dy)&&s[dx][dy]>s[x][y])
                {
                    int a = DFS(dx,dy);
                    if(a>MAX)
                        MAX = a;
                }
            }
        }
        dp[x][y] = MAX + s[x][y];
        return dp[x][y];
    }
    
    int main()
    {
        int i,j;
        while(cin>>n>>k)
        {
            if(n==-1&&k==-1)
                break;
            for(i=0;i<n;i++)
                for(j=0;j<n;j++)
                    dp[i][j] = 0;
            for(i=0;i<n;i++)
                for(j=0;j<n;j++)
                    cin>>s[i][j];
            DFS(0,0);
            cout<<dp[0][0]<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    测试
    Python 学习笔记【15】文件操作
    Python 学习笔记【14】集合
    Python 学习笔记【13】练习:三级菜单
    Python 学习笔记【12】字典
    Python 学习笔记【11】字符串操作
    Python 学习笔记【10】练习:购物车程序
    Python 学习笔记【09】列表、元组
    Python 学习笔记【08】数据类型、数据运算、进制转换
    Python 学习笔记【07】PEP 8 中英对照
  • 原文地址:https://www.cnblogs.com/luoxiaoyi/p/9790747.html
Copyright © 2020-2023  润新知