• Java练习 SDUT-2272_Time


    Time

    Time Limit: 1000 ms Memory Limit: 65536 KiB

    Problem Description

    Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.

    Input

    There are several test cases.
    Each case contains 4 integers in a line, separated by space.
    Proceed to the end of file.

    Output

    For each test case, output the time expressed by the digital clock such as Sample Output.

    Sample Input

    1 2 5 6
    2 3 4 2

    Sample Output

    一道绘图题,这种题一直是弱项,头铁强制画了出来,浪费了挺多时间。而且整个人都狂燥了。
    结果看到这份代码

    • z_xindong的代码
      瞬间清醒了,其实用三维数组存一下就可以了。(String开二维就好)
    import java.util.Scanner;
     
    public class Main{
     
    	public static void main(String[] args) {
    		Scanner cin=new Scanner(System.in);
    		 String[][] time=new String[][]{
                     {" _ ","   "," _ "," _ ","   "," _ "," _ "," _ "," _ "," _ "},
                     {"| |","  |"," _|"," _|","|_|","|_ ","|_ ","  |","|_|","|_|"},
                     {"|_|","  |","|_ "," _|","  |"," _|","|_|","  |","|_|"," _|"}};
    		    
    		while(cin.hasNext()){
    			int[] a=new int[4];
    			for(int i=0;i<4;i++){
    				a[i]=cin.nextInt();
    			}
    			for (int i = 0; i < 3; i++) {
    				for (int j = 0; j < 4; j++) {
    					System.out.print(time[i][a[j]]);
    				}
    				System.out.println();
    			}			
    		}
    	} 
    }
    
  • 相关阅读:
    【BZOJ4903】
    nuxt中引入svg
    vue-spa微信分享,在ios端,分享不成功的原因及解决办法
    安装包
    nuxt中刷新页面后防止store值丢失
    nuxt项目如何设置代理接口
    nuxt引入jquery和bootstrap
    如何在nuxt中引入scss
    创建nuxt项目
    微信分享
  • 原文地址:https://www.cnblogs.com/luoxiaoyi/p/9712968.html
Copyright © 2020-2023  润新知