• The 15th Zhejiang Provincial Collegiate Programming Contest Sponsored by TuSimple


    Lucky 7

    Time Limit: 1 Second      Memory Limit: 65536 KB

    BaoBao has just found a positive integer sequence  of length  from his left pocket and another positive integer  from his right pocket. As number 7 is BaoBao's favorite number, he considers a positive integer  lucky if  is divisible by 7. He now wants to select an integer  from the sequence such that  is lucky. Please tell him if it is possible.

    Input

    There are multiple test cases. The first line of the input is an integer  (about 100), indicating the number of test cases. For each test case:

    The first line contains two integers  and  (), indicating the length of the sequence and the positive integer in BaoBao's right pocket.

    The second line contains  positive integers  (), indicating the sequence.

    Output

    For each test case output one line. If there exists an integer  such that  and  is lucky, output "Yes" (without quotes), otherwise output "No" (without quotes).

    Sample Input

    4
    3 7
    4 5 6
    3 7
    4 7 6
    5 2
    2 5 2 5 2
    4 26
    100 1 2 4
    

    Sample Output

    No
    Yes
    Yes
    Yes
    

    Hint

    For the first sample test case, as 4 + 7 = 11, 5 + 7 = 12 and 6 + 7 = 13 are all not divisible by 7, the answer is "No".

    For the second sample test case, BaoBao can select a 7 from the sequence to get 7 + 7 = 14. As 14 is divisible by 7, the answer is "Yes".

    For the third sample test case, BaoBao can select a 5 from the sequence to get 5 + 2 = 7. As 7 is divisible by 7, the answer is "Yes".

    For the fourth sample test case, BaoBao can select a 100 from the sequence to get 100 + 26 = 126. As 126 is divisible by 7, the answer is "Yes".

    原题地址:http://acm.zju.edu.cn/onlinejudge/showContestProblem.do?problemId=5762

    题意:

    给你一个n,和b,然后一个长度为n的数组A 问你是否有数组A的元素加上B能被7整除 如果可以输出Yes,不能输出No

    代码:

    #include<bits/stdc++.h>
    using namespace std;
    
    int a[5000000];
    int main()
    {
        std::ios::sync_with_stdio(false);
        int t;
        while(cin>>t){
            while(t--){
            int n,num;
            cin>>n>>num;
            int flag=0;
            for(int i=0;i<n;i++){
                    cin>>a[i];
            }
            for(int i=0;i<n;i++){
                    if((a[i]+num)%7==0){
                            flag=1;break;
                    }
            }
            if(flag)cout<<"Yes"<<endl;
            else cout<<"No"<<endl;
        }
        }
        return 0;
    }
  • 相关阅读:
    RMAN 增量备份 的 对象测试
    小论工具类App的盈利之道
    linux下二进制文件比较程序
    [置顶] 对iOS开发有用的一些自动化处理脚本
    [Win8]Windows8开发笔记(八):数据绑定的基础
    NetBeans 时事通讯(刊号 # 116 Sep 11, 2010)
    域名信息证实 JavaEye 已被 CSDN 收购
    插件架构简介
    GAE for Java exception: no matching index found.
    Java 7 最快要到 2012 年中发布
  • 原文地址:https://www.cnblogs.com/luowentao/p/8972793.html
Copyright © 2020-2023  润新知