• The Preliminary Contest for ICPC Asia Xuzhou 2019 徐州网络赛 D Carneginon


    Carneginon was a chic bard. But when he was young, he was frivolous and had joined many gangs. Recently, Caneginon was to be crowned, because the king was shocked by his poems and decided to award him the gold medal lecturer. Therefore, Most of people in the Kingdom came to visit him.

    However, as a medal lectirer, Carneginon must treat the visitors kindly, including elders and younger generations. In order to maintain order, every visitor received a license with a magic field engraved on it. And the magic field on the licence was made up of lowercase letters.

    Carneginon had a unique licence, which could judge whether others are his older or younger. Now, we assume that the sequence on Carneginon's licence is TT and the sequence on visitors' licence is SS. For each visitor,

    • If the length of TT is longer than the length of SS, it's obviously that the visitor is younger. And if SS is a substring of TT, Carneginon would call the visitor my child!. Otherwise, Carneginon would call the visitor oh, child!.

    • If the length of TT is less than the length of SS, it's obviously that the visitor is elder. And if TT is a substring of SS, Carneginon would call the visitor my teacher!. Otherwise, Carneginon would call the visitor senior!.

    • Of course, if the length of TT is equal to the length of SS, the visitor is Carneginon's peer. And if TT is equal to SS, it shows that the visitor entered through an improper way and Carneginon would shout jntm!. Otherwise, Carneginon would call the visitor friend!.

    Now, you know the TT (Carneginon's licence), qq (the number of visitors) and each visitor's licence(S_iSi​). Can you judge what Caneginon needs to say when he sees every visitor?

    Input

    The first line is a string TT, representing Carneginon's license.

    The second line is and integer qq, which means the number of visitors.

    Then mm lines, for each line, there is a string SS, denoting the visitor's license.

    1 leq |T| leq 10^51≤∣T∣≤105, 1 leq |S| leq 10^51≤∣S∣≤105, 1 leq q leq 10001≤q≤1000

    It is guaranteed that q imes (|S|+|T|) leq 10^7q×(∣S∣+∣T∣)≤107.

    Output

    There are qq lines.

    For each SS, output what Carneginon should say correctly.

    样例输入复制

    abcde
    6
    abcde
    aaaaa
    abcd
    aaaa
    abcdef
    abccdefg

    样例输出复制

    jntm!
    friend!
    my child!
    oh, child!
    my teacher!
    senior!

    这个题简单KMP匹配,直接套模板,就ok,一A;

    #define _CRT_SECURE_NO_WARNINGS
    #include<iostream>
    #include<queue>
    #include<algorithm>
    #include<set>
    #include<cmath>
    #include<vector>
    #include<map>
    #include<stack>
    #include<bitset>
    #include<cstdio>
    #include<cstring>
    #define Swap(a,b) a^=b^=a^=b
    #define cini(n) scanf("%d",&n)
    #define cinl(n) scanf("%lld",&n)
    #define cinc(n) scanf("%c",&n)
    #define cins(s) scanf("%s",s)
    #define coui(n) printf("%d",n)
    #define couc(n) printf("%c",n)
    #define coul(n) printf("%lld",n)
    #define speed ios_base::sync_with_stdio(0)
    #define Max(a,b) a>b?a:b
    #define Min(a,b) a<b?a:b
    #define mem(n,x) memset(n,x,sizeof(n))
    #define INF  0x3f3f3f3f
    #define maxn  100010
    #define esp  1e-9
    #define mp(a,b) make_pair(a,b)
    using namespace std;
    typedef long long ll;
    //-----------------------*******----------------------------//
    int nextt[100005];
    void Getnextt(string &p,int nextt[])
    {
        int pLen = p.size();
        nextt[0] = -1;
        int k = -1;
        int j = 0;
        while (j < pLen - 1)
        {
            //p[k]表示前缀,p[j]表示后缀
            if (k == -1 || p[j] == p[k])
            {
                ++k;
                ++j;
                nextt[j] = k;
            }
            else
            {
                k = nextt[k];
            }
        }
    }
    bool KmpSearch(string &s, string &p)
    {
        int i = 0;
        int j = 0;
        int sLen = s.size();
        int pLen = p.size();
        while (i < sLen && j < pLen)
        {
            //①如果j = -1,或者当前字符匹配成功(即S[i] == P[j]),都令i++,j++
            if (j == -1 || s[i] == p[j])
            {
                i++;
                j++;
            }
            else
            {
                //②如果j != -1,且当前字符匹配失败(即S[i] != P[j]),则令 i 不变,j = nextt[j]
                //nextt[j]即为j所对应的nextt值
                j = nextt[j];
            }
        }
        if (j == pLen)
            return true;
        else
            return false;
    }
    int main()
    {
        string s,w;
        int n;
        cin>>s>>n;
    int     len=s.size();
        while(n--)
        {   memset(nextt,0,sizeof(nextt));
            cin>>w;
            int x=w.size();
           // cout<<x<<' '<<len<<endl;
            if(x==len)
            {
               // cout<<-1<<endl;
                if(w==s) puts("jntm!");
                else puts("friend!");
            }
            else if(x<len)
            {   Getnextt(w,nextt);
                if(KmpSearch(s, w))  //w s
                puts("my child!");
                else
                puts("oh, child!");
            }
            else
            {
                Getnextt(s,nextt);
                if(KmpSearch(w, s))
                 puts("my teacher!");
                    else puts("senior!");
            }
        }
    }
  • 相关阅读:
    PHP用*号替代姓名除第一个字之外的字符
    苹果笔记本下载的应用打不开或提示损坏怎么办
    codeigniter教程:Codeigniter出现Unable to connect to your databas
    Python3.6.0安装
    某游戏应用的redis 数据库结构设计(转)
    True(False) Positives (Negatives), 召回率和精度定义
    儿童书库
    年轻人必须知道的71个做饭技巧
    20种泡菜做法[3到5天就可以吃了]
    读懂此文——股市就是你的取款机
  • 原文地址:https://www.cnblogs.com/lunatic-talent/p/12798749.html
Copyright © 2020-2023  润新知