Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
Input
each test case contains two numbers A and B.
Output
for each case, if A is equal to B, you should print "YES", or print "NO".
Sample Input
1 2
2 2
3 3
4 3
Sample Output
NO
YES
YES
NO
题意很简单,但是涉及到的位数非常多,其次是前导零,然后是精度的后导零,给组样例:
0000123.555 000000000000000000000123.55500000000000000000000000000000000000000000
import java.math.BigDecimal;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
while (cin.hasNext()) // 多组输入
{
BigDecimal a = cin.nextBigDecimal();
BigDecimal b = cin.nextBigDecimal();
if(a.compareTo(b)==0)System.out.println("YES");
else System.out.println("NO");
}
}
}