• HDU


    Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

    seed(x+1) = [seed(x) + STEP] % MOD

    where '%' is the modulus operator.

    Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

    For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

    If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

    Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

    Input

    Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

    Output

    For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.

    Sample Input

    3 5
    15 20
    63923 99999

    Sample Output

             3         5    Good Choice
    
            15        20    Bad Choice
    
         63923     99999    Good Choice

    此题其实是判断两个数是否互质,也就是最大公约数是否为1

    注意格式,,,,

    代码如下:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    
    int gcd(int a,int b)
    {
        return b == 0 ? a : gcd(b,a % b);
    }
    int main()
    {
        int a,b,c;
        while(~scanf("%d%d",&a,&b))
        {
            printf("%10d%10d",a,b);
            c = gcd(a,b);
            if(c == 1)
            printf("    Good Choice
    
    ");
            else
            printf("    Bad Choice
    
    ");
        }
        return 0;
    }
    
  • 相关阅读:
    Windows 2003安全配置最佳方法(转)
    令人十分怨念的tomcat注册成windows服务(转)
    AMR开源编码jrtplib中与int系统重定义问题解决
    由系统熵转移的思考
    此男因为什么被送进医院?
    [转]风水师的郁闷
    飞盘奇门局例我能顺利办好护照拿到签证出国参加会议吗?
    最近工作方面发生了一些大事情,所以特地为此摇了一挂,请高手进来断一断。
    概率面前的错误
    杜新会一个精彩占例之反推
  • 原文地址:https://www.cnblogs.com/lu1nacy/p/10016636.html
Copyright © 2020-2023  润新知