• Hdu 4035 Maze(概率DP)


     
    Problem Description
    When wake up, lxhgww find himself in a huge maze.

    The maze consisted by N rooms and tunnels connecting these rooms. Each pair of rooms is connected by one and only one path. Initially, lxhgww is in room 1. Each room has a dangerous trap. When lxhgww step into a room, he has a possibility to be killed and restart from room 1. Every room also has a hidden exit. Each time lxhgww comes to a room, he has chance to find the exit and escape from this maze.

    Unfortunately, lxhgww has no idea about the structure of the whole maze. Therefore, he just chooses a tunnel randomly each time. When he is in a room, he has the same possibility to choose any tunnel connecting that room (including the tunnel he used to come to that room).
    What is the expect number of tunnels he go through before he find the exit?
     
    Input
    First line is an integer T (T ≤ 30), the number of test cases.

    At the beginning of each case is an integer N (2 ≤ N ≤ 10000), indicates the number of rooms in this case.

    Then N-1 pairs of integers X, Y (1 ≤ X, Y ≤ N, X ≠ Y) are given, indicate there is a tunnel between room X and room Y.

    Finally, N pairs of integers Ki and Ei (0 ≤ Ki, Ei ≤ 100, Ki + Ei ≤ 100, K1 = E1 = 0) are given, indicate the percent of the possibility of been killed and exit in the ith room.
     
    Output
    For each test case, output one line “Case k: ”. k is the case id, then the expect number of tunnels lxhgww go through before he exit. The answer with relative error less than 0.0001 will get accepted. If it is not possible to escape from the maze, output “impossible”.
     
    Sample Input
    3 3 1 2 1 3 0 0 100 0 0 100 3 1 2 2 3 0 0 100 0 0 100 6 1 2 2 3 1 4 4 5 4 6 0 0 20 30 40 30 50 50 70 10 20 60
     
    Sample Output
    Case 1: 2.000000 Case 2: impossible Case 3: 2.895522
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<algorithm>
    using namespace std;
    
    const int N=1e4+5;
    const double eps=1e-9;
    
    int T,n;
    int deg[N];
    double A[N],B[N],C[N];
    double k[N],e[N];
    
    int head[N],num_edge;
    struct Edge
    {
        int v,nxt;
    }edge[N<<1];
    
    inline void add_edge(int u,int v)
    {
        edge[++num_edge].v=v;
        edge[num_edge].nxt=head[u];
        head[u]=num_edge;
    }
    
    bool dfs(int u,int fa)
    {
        double m=deg[u];
        A[u]=k[u];
        B[u]=(1-k[u]-e[u])/m;
        C[u]=1-k[u]-e[u];
        double tmp=1,ratio=B[u];
        for(int i=head[u],v;i;i=edge[i].nxt)
        {
            v=edge[i].v;
            if(v==fa)
                continue;
            if(!dfs(v,u))
                return false;
            tmp-=ratio*B[v];
            A[u]+=ratio*A[v];
            C[u]+=ratio*C[v];
        }
        if(fabs(tmp)<=eps)
            return false;
        A[u]/=tmp;
        B[u]/=tmp;
        C[u]/=tmp;
        return true;
    }
    
    int taskid;
    int main()
    {
        scanf("%d",&T);
        while(T--)
        {
            memset(deg,0,sizeof(deg));
            memset(head,0,sizeof(head));
            num_edge=0;
            scanf("%d",&n);
            for(int i=1,a,b;i<n;++i)
            {
                scanf("%d%d",&a,&b);
                ++deg[a],++deg[b];
                add_edge(a,b);
                add_edge(b,a);
            }
            for(int i=1;i<=n;++i)
            {
                scanf("%lf%lf",k+i,e+i);
                k[i]/=100,e[i]/=100;
            }
            cout<<"Case "<<++taskid<<": ";
            if(dfs(1,1)&&fabs(1-A[1])>eps)
                cout<<C[1]/(1-A[1])<<'
    ';
            else
                puts("impossible");
        }
        
        return 0;
    }
  • 相关阅读:
    验证码帮助类
    UDP聊天
    SoapHeader的使用
    单条目选择控件
    Redis命令总结
    PHP解决抢购、秒杀、抢楼、抽奖等阻塞式高并发库存防控超量的思路方法
    Python3经典100道练习题004
    Python3经典100道练习题001
    tkinter笔记01创建第一GUI
    Python3经典100道练习题006
  • 原文地址:https://www.cnblogs.com/lovewhy/p/9788362.html
Copyright © 2020-2023  润新知