• HDU 1524


    A Chess Game

    Problem Description
    Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again. 

    Do you want to challenge me? Just write your program to show your qualification!
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.
     
    Output
    There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.
     
    Sample Input
    4
    2 1 2
    0
    1 3
    0
    1 0
    2 0 2
    0
     
     
    4
    1 1
    1 2
    0
    0
    2 0 1
    2 1 1
    3 0 1 3
    0
     
    Sample Output
    WIN
    WIN
    WIN
    LOSE
    WIN
     
    Source
     
    题意是给出一个有向无环图,在图上有若干棋子,轮流移动棋子,轮到谁不能动了,他就输了。
    简单的求sg函数,dfs搞一搞。
     
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    vector<int> r[1010];
    int g[1010];
    void init() {
        memset(g, -1, sizeof(g));
        for(int i = 0; i <= 1005; i++) {
            r[i].clear();
        }
    }
    int getSG(int x) {
        if(g[x] != -1) return g[x];
        if(r[x].size() == 0) return 0;
        int vis[1010];
        memset(vis, 0, sizeof(vis));
        for(int i = 0; i < r[x].size(); i++) {
            g[r[x][i]] = getSG(r[x][i]);
            vis[g[r[x][i]]] = 1;
            //puts("check");
        }
        for(int i = 0; ; i++) if(!vis[i])
            return i;
        //puts("check");
    }
    int main() {
        int n;
        while(~scanf("%d", &n)) {
            init();
            for(int i = 0; i < n; i++) {
                int m; scanf("%d", &m);
                for(int j = 1; j <= m; j++) {
                    int v;
                    scanf("%d", &v);
                    r[i].push_back(v);
                }
            }
            int m, v, flag;
            while(scanf("%d", &m)) {
                if(m == 0) break;
                flag = 0;
                while(m--) {
                    scanf("%d", &v);
                    if(g[v] == -1)
                        g[v] = getSG(v);
                    flag ^= g[v];
                }
                if(flag == 0) puts("LOSE");
                else puts("WIN");
            }
        }
    }
     
  • 相关阅读:
    Centos R安装
    python 排序函数L.sort()和sorted()
    系统评测指标:准确率(Accuracy)、精确率(Precision)、召回率(Recall)、F-Score
    linux exec使用小结
    linux 日志文件
    数据结构中的八大排序算法
    Boyer-Moore(BM)算法,文本查找,字符串匹配问题
    内存为程序分配空间的四种分配方式
    内部碎片、外部碎片
    函数调用过程栈帧变化详解
  • 原文地址:https://www.cnblogs.com/lonewanderer/p/5697163.html
Copyright © 2020-2023  润新知