• hdu 1385(Floyed+打印路径好题)


    Minimum Transport Cost

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9814    Accepted Submission(s): 2641


    Problem Description
    These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
    The cost of the transportation on the path between these cities, and

    a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

    You must write a program to find the route which has the minimum cost.
     
    Input
    First is N, number of cities. N = 0 indicates the end of input.

    The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

    a11 a12 ... a1N
    a21 a22 ... a2N
    ...............
    aN1 aN2 ... aNN
    b1 b2 ... bN

    c d
    e f
    ...
    g h

    where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
     
    Output
    From c to d :
    Path: c-->c1-->......-->ck-->d
    Total cost : ......
    ......

    From e to f :
    Path: e-->e1-->..........-->ek-->f
    Total cost : ......

    Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

     
    Sample Input
    5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
     
    Sample Output
    From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
     
    Source
     
    path数组用得太好了。。想不到啊。。floyed的理解要相当深入才行
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <iostream>
    using namespace std;
    typedef long long LL;
    const int N = 200;
    const int INF = 999999999;
    int graph[N][N];
    int path[N][N];
    int cost[N];
    int main()
    {
        int n;
        while(~scanf("%d",&n),n){
            for(int i=1;i<=n;i++){
                for(int j=1;j<=n;j++){
                    scanf("%d",&graph[i][j]);
                    if(graph[i][j]==-1) graph[i][j] = INF;
                    path[i][j]=j;
                }
            }
            for(int i=1;i<=n;i++) scanf("%d",&cost[i]);
            for(int k=1;k<=n;k++){
                for(int i=1;i<=n;i++){
                    for(int j=1;j<=n;j++){
                        if(graph[i][j]>graph[i][k]+graph[k][j]+cost[k]){
                            graph[i][j] = graph[i][k]+graph[k][j]+cost[k];
                            path[i][j]=path[i][k];
                        }
                        else if(graph[i][j]==graph[i][k]+graph[k][j]+cost[k]&&path[i][j] > path[i][k]){
                            path[i][j]=path[i][k];
                        }
                    }
                }
            }
            int a,b;
            while(~scanf("%d%d",&a,&b)){
                if(a==-1&&b==-1) break;
                printf("From %d to %d :
    Path: %d",a,b,a);
                int u =a,v=b;
                while(u!=v){
                    printf("-->%d",path[u][v]);
                    u = path[u][v];
                }
                printf("
    Total cost : %d
    
    ", graph[a][b]);
            }
    
        }
        return 0;
    }
  • 相关阅读:
    SQL中的count()函数内加条件
    SpringBoot+Vue实现第三方微博登录(二)
    SpringBoot+Vue实现第三方百度登录(一)
    Javascript unescape 的 Sql Server 实现
    DataGridView 行内编辑探索
    JQuery Offset实验与应用
    垃圾代码是这样练成的......
    关于前天发现的可能是VS2005服务器资源管理器的bug ...
    调试
    可怕的误导,来自(iHeavy Inc.公司的高级顾问Sean Hull的谬论... )
  • 原文地址:https://www.cnblogs.com/liyinggang/p/5528944.html
Copyright © 2020-2023  润新知