• hdu 1325(并查集)


    Is It A Tree?

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 19907    Accepted Submission(s): 4472


    Problem Description
    A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
    There is exactly one node, called the root, to which no directed edges point.

    Every node except the root has exactly one edge pointing to it.

    There is a unique sequence of directed edges from the root to each node.

    For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



    In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

     
    Input
    The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
     
    Output
    For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
     
    Sample Input
    6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
     
    Sample Output
    Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
     
    Source
     
    判断有向图是否为树:
    1,每个点的入度都不大于一
    2,已经标记的点树根是自己的数量只能等于1,不然就是森林
    3,不能成环
    4,0 0也是树
    package 并查集;
    
    import java.util.Scanner;
    
    public class hdu_1325 {
        static int [] father;
        static int [] indegree;
        static boolean [] flag;  
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int k = 1;
            while(true){
                boolean istree=true;
                father = new int [1000];
                indegree = new int [1000];
                flag = new boolean [1000];
                int x = sc.nextInt();
                int y =sc.nextInt();
                if(x<0&&y<0) break;
                if(x==0&&y==0){   //空树也是树
                    System.out.println("Case "+(k++)+" is a tree.");
                    continue;
                }
                for(int i=1;i<1000;i++){
                    father[i] = i;    
                }
                while(true){
                    if(x==0&&y==0) break;
                    int a = find(x);
                    int b = find(y);
                    flag[x] = true;
                    flag[y] = true;
                    if(a!=b) {
                        father[a] = b;
                        indegree[y]++;  //入度加一
                    }
                    if(a==b) istree = false;  //成环
                    x = sc.nextInt();
                    y = sc.nextInt();
                }
                int ans = 0;
                for(int i=1;i<1000;i++){
                    if(indegree[i]>1) {
                        istree = false;  //度大于一
                    }
                    if(flag[i]&&father[i]==i) ans++;  //这个点被标记过了并且自己还是一棵树的根
                    if(ans>1) istree = false;  //森林
                }
                if(istree) System.out.println("Case "+(k++)+" is a tree.");
                else System.out.println("Case "+(k++)+" is not a tree.");
            }
        }
        private static int find(int x) {
            if(x==father[x]) return x;
            return find(father[x]);
        }
    }
  • 相关阅读:
    iOS 怎么在一个函数执行完毕得到某个参数值后再去执行他下边的代码
    微信小程序开发(三)-----手动创建目录结构
    微信小程序开发(二)-----项目的创建
    微信小程序开发(一)-----工具的安装
    Block传值讲解与使用
    Mybatis xml约束文件的使用
    Spark Streaming 整合 Kafka
    Scala 大数据 常用算法收集
    WPF自定义动画控件 风机
    wpf 错误 执行了 QueryInterface 调用,请求提供 COM 可见的托管类“BoilerMonitoringV1._0.MapControl”的默认 IDispatch 接口。
  • 原文地址:https://www.cnblogs.com/liyinggang/p/5317125.html
Copyright © 2020-2023  润新知