转自博客园ID:2108,老卢同志
http://www.cnblogs.com/--ZHIYUAN/p/6102893.html
Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19589 Accepted Submission(s): 13709
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4 10 20
Sample Output
5 42 627
Author
Ignatius.L
题意:
拆数共有多少总方案
代码:
/*//整数拆分模板 #include <iostream> using namespace std; const int lmax=10000; //c1是用来存放展开式的系数的,而c2则是用来计算时保存的, //他是用下标来控制每一项的位置,比如 c2[3] 就是 x^3 的系数。 //用c1保存,然后在计算时用c2来保存变化的值。 int c1[lmax+1],c2[lmax+1]; int main() { int n, i, j, k ; // 计算的方法还是模拟手动运算,一个括号一个括号的计算, // 从前往后 while ( cin>>n ) { //对于 1+x+x^2+x^3+ 他们所有的系数都是 1 // 而 c2全部被初始化为0是因为以后要用到 c2[i] += x ; for ( i=0; i<=n; i++ ) { c1[i]=1; c2[i]=0; } //第一层循环是一共有 n 个小括号,而刚才已经算过一个了 //所以是从2 到 n for (i=2; i<=n; i++) { // 第二层循环是把每一个小括号里面的每一项,都要与前一个 //小括号里面的每一项计算。 for ( j=0; j<=n; j++ ) //第三层小括号是要控制每一项里面 X 增加的比例 // 这就是为什么要用 k+= i ; for ( k=0; k+j<=n; k+=i ) { // 合并同类项,他们的系数要加在一起,所以是加法,呵呵。 // 刚开始看的时候就卡在这里了。 c2[ j+k] += c1[ j]; } // 刷新一下数据,继续下一次计算,就是下一个括号里面的每一项。 for ( j=0; j<=n; j++ ) { c1[j] = c2[j] ; c2[j] = 0 ; } } cout<<c1[n]<<endl; } return 0; }
#include<bitsstdc++.h> using namespace std; int c1[123],c2[123]; void solve() { for(int i=0;i<=120;i++) { c1[i]=1; c2[i]=0; } for(int k=2;k<=120;k++) { for(int i=0;i<=120;i++) for(int j=0;j+i<=120;j+=k) c2[j+i]+=c1[i]; for(int i=0;i<=120;i++) { c1[i]=c2[i]; c2[i]=0; } } } int main() { int n; solve(); while(scanf("%d",&n)!=EOF) { printf("%d ",c1[n]); } return 0; }