• HDU-1548--A strange lift--(BFS,剪枝)


    A strange lift

     
    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 945 Accepted Submission(s): 450

    Problem Description
    There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
    Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button "UP" or "DOWN"?
     

    Input
    The input consists of several test cases.,Each test case contains two lines.
    The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
    A single 0 indicate the end of the input.
     

    Output
    For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
     

    Sample Input
    5 1 5
    3 3 1 2 5
    0
     

    Sample Output
    3
     

     
     
    Recommend
    8600

    做地图搜索做到恶心,终于来了道换种问法的,其实还是一样。。。。(汗。。。

    这道题如果裸搜索,不剪枝的话,会超时

    于是用一个vis数组标记一下此电梯是否访问到,如果访问到就无需加入到队列中(此时队列中的状态一定是从已访问的那一层得来的)

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<cmath>
    #include<map>
    #include<iomanip>
    #include<queue>
    #define INF 0x7ffffff
    #define MAXN 220
    using namespace std;
    const double eps=1e-10;
    int n,a,b;
    struct node
    {
        int f,step;
    };
    int k[MAXN];
    int vis[MAXN];
    int bfs()
    {
        int x;
        queue<struct node> q;
        struct node pre,now;
        pre.f=a;pre.step=0;
        q.push(pre);
        vis[a]=1;
        while(!q.empty()){
            pre=q.front();
            q.pop();
            if(pre.f==b)
                return pre.step;
            x=pre.f;
            now=pre;
            now.step++;
            if(x+k[x]<=n&&vis[x+x[k]]==0){
                vis[x+x[k]]=1;
                now.f+=k[x];
                q.push(now);
                now.f-=k[x];
            }
            if(x-k[x]>=1&&vis[x-x[k]]==0){
                vis[x-x[k]]=1;
                now.f-=k[x];
                q.push(now);
            }
        }
        return -1;
    }
    int main()
    {
        #ifndef ONLINE_JUDGE
        freopen("data.in", "r", stdin);
        #endif
        std::ios::sync_with_stdio(false);
        std::cin.tie(0);
        int res;
        while(cin>>n&&n!=0){
            memset(vis,0,sizeof(vis));
            cin>>a>>b;
            for(int i=1;i<=n;i++){
                cin>>k[i];
            }
            res=bfs();
            if(res==-1)
                cout<<-1<<endl;
            else cout<<res<<endl;
        }
    }
  • 相关阅读:
    开发工具 之 PowerDesigner 应用积累
    PowerDesigner 之 PDM建模
    开发工具 之 PowerDesigner
    LCD 和 LED 的区别?
    图像色彩空间YUV和RGB的差别
    ubuntu使用中的一些问题
    FFMPEG-数据结构解释(AVCodecContext,AVStream,AVFormatContext)
    Winform的多线程问题
    C#子线程更新UI控件的方法总结
    malloc(0)的问题
  • 原文地址:https://www.cnblogs.com/liuzhanshan/p/6052214.html
Copyright © 2020-2023  润新知