• 1129 Recommendation System (25分)


    Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

    Input Specification:

    Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

    Output Specification:

    For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

    query: rec[1] rec[2] ... rec[K]
    
     

    where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

    Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

    Sample Input:

    12 3
    3 5 7 5 5 3 2 1 8 3 8 12
    
     

    Sample Output:

    5: 3
    7: 3 5
    5: 3 5 7
    5: 5 3 7
    3: 5 3 7
    2: 5 3 7
    1: 5 3 2
    8: 5 3 1
    3: 5 3 1
    8: 3 5 1
    12: 3 5 8

    这题考察top N,我们可以进行重载<符号,之后set会根据<里面的逻辑进行排序,这样即可达到O(logn)的复杂度,依次插入,打印top N,即可。

    #include <iostream>
    #include <set>
    #include <unordered_map>
    using namespace std;
    struct node {
        int k, v;
        bool operator < (const node& n) const {
            return v != n.v ? v > n.v : k < n.k;
        }
    };
    int N, K, tmp;
    set<node> s;
    unordered_map<int, int> m;
    int main() {
        scanf("%d%d", &N, &K);
        scanf("%d", &tmp);
        m[tmp]++; s.insert({tmp, m[tmp]});
        for(int i = 1; i < N; i++) {
            scanf("%d", &tmp);
            printf("%d:", tmp);
            auto it = s.begin();
            for(int i = 0; i < K && it != s.end(); i++, it++)
                printf(" %d", it->k);
            putchar('
    ');
            it = s.find({tmp, m[tmp]});
            if(it != s.end()) s.erase(it);
            m[tmp]++;
            s.insert({tmp, m[tmp]});
        }
        return 0;
    }
  • 相关阅读:
    表单元素input与文字对齐
    css hack较全
    闭合浮动
    字体
    css中z-index属性(包含各浏览器对此兼容问题)
    ie中使用滤镜实现css3的效果
    css实现提示框
    css3实现渐变效果
    css伪类
    .net core运用application/x-www-form-urlencoded发起post请求
  • 原文地址:https://www.cnblogs.com/littlepage/p/12831786.html
Copyright © 2020-2023  润新知