• PAT Advanced


    The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

    • Itai nyan~ (It hurts, nyan~)

    • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case. For each case, the first line is an integer N (2). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

    Sample Input 1:

    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
    
     

    Sample Output 1:

    nyan~
    
     

    Sample Input 2:

    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
    
     

    Sample Output 2:

    nai

    可能太久不用Java写东西了,感觉有点爽,之前乙级用cpp写了

    import java.util.Scanner;
    public class Main {
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int n = Integer.parseInt(sc.nextLine()), minLen = 99999999;
            String[] str = new String[n];
            for(int i = 0; i < n; i++) {
                str[i] = new StringBuilder(sc.nextLine()).reverse().toString();
                if(str[i].length() < minLen) minLen = str[i].length();
            }
            for(int i = 0; i < minLen; i++) {
                boolean same = true;
                for(int j = 1; j < n; j++) 
                    if(str[j].charAt(i) != str[j-1].charAt(i)) {
                        same = false;
                        break;
                    }
                if(!same) {
                    minLen = i;
                    break;
                }
            }
            if(minLen == 0) System.out.println("nai");
            else System.out.println(new StringBuilder(str[0].substring(0,minLen)).reverse());
        }
    }
  • 相关阅读:
    js Object.freeze()
    js Object.seal()
    js数字千分位,三种写法,,拿走。。。
    nodejs mongoose连接mongodb报错,command find requires authentication
    nodejs express 服务代理
    容器监控之cadvisor
    kubernetes 集群卸载清理
    解决目录太大-建立软链接
    与运算(&)、或运算(|)、异或运算(^)
    jpa中将查询的字段返回为Map键值对类型
  • 原文地址:https://www.cnblogs.com/littlepage/p/12247435.html
Copyright © 2020-2023  润新知