• PAT Advanced 1024 Palindromic Number (25分)


    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤) is the initial numer and K (≤) is the maximum number of steps. The numbers are separated by a space.

    Output Specification:

    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

    Sample Input 1:

    67 3
    
     

    Sample Output 1:

    484
    2
    
     

    Sample Input 2:

    69 3
    
     

    Sample Output 2:

    1353
    3

    这题用Java贼方便,直接逆序相加,用BigInteger不用考虑溢出问题。

    import java.math.BigInteger;
    import java.util.Scanner;
    public class Main {
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            BigInteger b = sc.nextBigInteger();
            int cnt = sc.nextInt(), i;
            for(i = 0; i < cnt; i++) 
                if(b.toString().equals(new StringBuilder(b.toString()).reverse().toString())) break;
                else b = new BigInteger(new StringBuilder(b.toString()).reverse().toString()).add(b);
            System.out.println(b + "
    " + i);
        }
    }
  • 相关阅读:
    python统计代码总行数(代码行、空行、注释行)
    selenium常用的API(二)浏览器窗口设置
    selenium常用的API(一)截屏
    python中的yield
    python中的lambda、map、reduce、filter
    python中的exec和eval
    MySQL中的information_schema
    单元测试框架Unittest
    MySQL批量修改相同后缀表名
    【python自动化第十一篇】
  • 原文地址:https://www.cnblogs.com/littlepage/p/12247426.html
Copyright © 2020-2023  润新知