• PAT Advanced 1012 The Best Rank (25分)


    To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

    For example, The grades of CME and A - Average of 4 students are given as the following:

    StudentID  C  M  E  A
    310101     98 85 88 90
    310102     70 95 88 84
    310103     82 87 94 88
    310104     91 91 91 91
    
     

    Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

    Output Specification:

    For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

    The priorities of the ranking methods are ordered as A C M E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

    If a student is not on the grading list, simply output N/A.

    Sample Input:

    5 6
    310101 98 85 88
    310102 70 95 88
    310103 82 87 94
    310104 91 91 91
    310105 85 90 90
    310101
    310102
    310103
    310104
    310105
    999999
    
     

    Sample Output:

    1 C
    1 M
    1 E
    1 A
    3 A
    N/A
    
     

    这道题考察排序,注意rank,是有并列第一的。

    #include <iostream>
    #include <vector>
    #include <algorithm>
    using namespace std;
    struct stu {
        string id;
        int score[4],r[4];
    };
    int choice;
    bool cmp(stu s1, stu s2) {
        return s1.score[choice] > s2.score[choice];
    }
    vector<stu> v;
    int main() {
        int M, N;
        cin >> M >> N;
        stu tmp;
        for(int i = 0; i < M; i++) {
            cin >> tmp.id >> tmp.score[0] >> tmp.score[1] >> tmp.score[2];
            tmp.score[3] = tmp.score[0] + tmp.score[1] + tmp.score[2];
            v.push_back(tmp);
        }
        for(choice = 0; choice < 4; choice++) {
            sort(v.begin(), v.end(), cmp);
            v[0].r[choice] = 1;
            for(int i = 1; i < M; i++) {
                if(v[i].score[choice] == v[i-1].score[choice])
                    v[i].r[choice] = v[i-1].r[choice];
                else v[i].r[choice] = i + 1;
            }
        }
        while(N--) {
            cin >> tmp.id;
            int i;
            for(i = 0; i < M; i++)
                if(tmp.id == v[i].id) break;
            if(i == M) {
                cout << "N/A" << endl;
                continue;
            }
            int a = v[i].r[3],c = v[i].r[0],m = v[i].r[1],e = v[i].r[2];
            if(a <= c && a <= m && a <= e)
                cout << a << " " << "A" << endl;
            else if(c <= a && c <= m && c <= e)
                cout << c << " " << "C" << endl;
            else if(m <= c && m <= a && m <= e)
                cout << m << " " << "M" << endl;
            else if(e <= c && e <= m && e <= a)
                cout << e << " " << "E" << endl;
        }
        system("pause");
        return 0;
    }
  • 相关阅读:
    如何手动编译运行带包 java 程序
    java计算时间差 Java问题通用解决代码
    Java除法结果带小数、进一法的实现 Java问题通用解决代码
    java中按字节获得字符串长度的两种方法 Java问题通用解决代码
    java精确除法计算,四舍五入 Java问题通用解决代码
    java 根据生日计算年龄 Java问题通用解决代码
    java统计中英文字数 Java问题通用解决代码
    java 实现新浪微博内容计数器 Java问题通用解决代码
    java代理ip有效检测
    java 实现统计某段文字在内容中出现的次数
  • 原文地址:https://www.cnblogs.com/littlepage/p/12246966.html
Copyright © 2020-2023  润新知