• PAT Advanced 1035 Password (20分)


    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (≤), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    
     

    Sample Output 1:

    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    
     

    Sample Input 2:

    1
    team110 abcdefg332
    
     

    Sample Output 2:

    There is 1 account and no account is modified
    
     

    Sample Input 3:

    2
    team110 abcdefg222
    team220 abcdefg333
    
     

    Sample Output 3:

    There are 2 accounts and no account is modified

    这道题考察了字符替换和逻辑,乙级有相同的题目。

    这边要注意的是输出时,单数是account,复数是accounts

    #include <iostream>
    #include <map>
    using namespace std;
    int main() {
        int N;
        cin >> N;
        string user, pw, res;
        map<char, char> m;
        m['l'] = 'L';m['O'] = 'o';
        m['1'] = '@';m['0'] = '%';
        int modicoun = 0;
        for(int j = 0; j < N; j++) {
            bool modi = false;
            cin >> user >> pw;
            for(int i = 0; i < pw.length(); i++){
                if(m[pw[i]] != 0) {
                    pw[i] = m[pw[i]];
                    modi = true;
                }
            }
            if(modi) {
                res = res + user + " " + pw + "
    ";
                modicoun++;
            }
        }
        if(!modicoun) {
            if(N != 1) printf("There are %d accounts and no account is modified", N);
            else printf("There is 1 account and no account is modified");
        }else {
            printf("%d
    %s", modicoun, res.c_str());
        }
        return 0;
    }
  • 相关阅读:
    Shared Memory in Windows NT
    Layered Memory Management in Win32
    软件项目管理的75条建议
    Load pdbs when you need it
    Stray pointer 野指针
    About the Rebase and Bind operation in the production of software
    About "Serious Error: No RTTI Data"
    Realizing 4 GB of Address Space[MSDN]
    [bbk4397] 第1集 第一章 AMS介绍
    [bbk3204] 第67集 Chapter 17Monitoring and Detecting Lock Contention(00)
  • 原文地址:https://www.cnblogs.com/littlepage/p/12239030.html
Copyright © 2020-2023  润新知