• PAT Advanced 1140 Look-and-say Sequence (20 分)


    Look-and-say sequence is a sequence of integers as the following:

    D, D1, D111, D113, D11231, D112213111, ...
    

    where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

    Input Specification:

    Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

    Output Specification:

    Print in a line the Nth number in a look-and-say sequence of D.

    Sample Input:

    1 8
    

    Sample Output:

    1123123111

    乙级真题

    #include <iostream>
    using namespace std;
    string coun(string str){
        string res="";int coun=1;
        for(int i=1;i<str.length();i++){
            if(str[i]==str[i-1]) coun++;
            else {
                res+=(str[i-1]);
                res+=(coun+'0');
                coun=1;
            }
        }
        res+=str[str.length()-1];res+=(coun+'0');
        return res;
    }
    int main()
    {
        string A;int B;
        cin>>A>>B;
        for(int i=1;i<B;i++) A=coun(A);
        cout<<A;
        system("pause");
        return 0;
    }
  • 相关阅读:
    使用ABP构建WebAPI的心得
    修改andriod模拟器的IMEI,IMSI,手机号,SIM卡号
    Abp框架下 Area中新建Layout报错的问题
    通过Roslyn构建自己的C#脚本 资料记录
    EF5 CodeFirst 修改主键自增属性
    Oracle字段类型及存储(一)
    ArcMap之等值面
    街景初看
    转:oracle中schema指什么
    OSGI起程一——确定目标
  • 原文地址:https://www.cnblogs.com/littlepage/p/11806280.html
Copyright © 2020-2023  润新知