• PAT Advanced 1073 Scientific Notation (20 分)


    Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

    Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

    Input Specification:

    Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

    Output Specification:

    For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

    Sample Input 1:

    +1.23400E-03
    

    Sample Output 1:

    0.00123400
    

    Sample Input 2:

    -1.2E+10
    

    Sample Output 2:

    -12000000000

    这道题目乙级有过,名字叫“科学计数法”

    #include <iostream>
    #include <deque>
    
    using namespace std;
    
    int main()
    {
        string str;
        cin>>str;
        char sign=str[0];
        deque<char> deque_Integer;//整数
        deque<char> deque_decimal;//小数
        int i;
        for(i=1;str[i]!='.';i++) deque_Integer.push_back(str[i]);
        for(i=i+1;str[i]!='E';i++) deque_decimal.push_back(str[i]);
        bool sign2=str[++i]=='+' ? 1:0;//获取符号,1右移,2左移
        int num=stoi(str.substr(i+1,str.length()-i-1));//左移或者右边移动的数量
        if(sign2){//右移
            while(num--){
                if(!deque_decimal.empty()){
                    deque_Integer.push_back(deque_decimal.front());
                    deque_decimal.pop_front();
                }else deque_Integer.push_back('0');
            }
        }else{//左移
            while(num--){
                if(!deque_Integer.empty()){
                    deque_decimal.push_front(deque_Integer.back());
                    deque_Integer.pop_back();
                }else deque_decimal.push_front('0');
            }
        }
        //输出
        if(sign!='+') cout<<sign;
        if(deque_Integer.size()==0) cout<<"0";
        else for(int i=0;i<deque_Integer.size();i++) cout<<deque_Integer[i];
        if(deque_decimal.size()!=0){
            cout<<".";
            for(int i=0;i<deque_decimal.size();i++) cout<<deque_decimal[i];
        }
        system("pause");
        return 0;
    }
  • 相关阅读:
    EF支持的注解
    c#数组去重复超级简单
    终于开通博客了。
    理解C#中参数
    一般处理程序中session问题
    小菜的面试所感
    为IOS生成opencv framework时遇到的2个问题
    纯真IP地址数据库qqwry.dat解析
    scala纯函数式编程-排序算法实现
    跳跃列表原理和实现
  • 原文地址:https://www.cnblogs.com/littlepage/p/11805196.html
Copyright © 2020-2023  润新知