• 数据结构课后练习题(练习三)7-5 Tree Traversals Again (25 分)


    7-5 Tree Traversals Again (25 分)
     

    An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


    Figure 1

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2 lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

    Output Specification:

    For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:

    6
    Push 1
    Push 2
    Push 3
    Pop
    Pop
    Push 4
    Pop
    Pop
    Push 5
    Push 6
    Pop
    Pop
    

    Sample Output:

    3 4 2 6 5 1

    #include <iostream>
    #include <vector>
    #include <stack>
    #include <cstring>
    
    using namespace std;
    
    vector<int> pre,in,post,val;
    
    void postorder(int root,int start,int end){
        if(start>end) return ;
        int root_index=0;
        while(root_index<=end&&in[root_index]!=pre[root]) root_index++;
        postorder(root+1,start,root_index-1);
        postorder(root+1+root_index-start,root_index+1,end);
        post.push_back(pre[root]);
    }
    int main()
    {
        stack<int> sta;
        int k=0,N;
        char ch[5];int num;
        scanf("%d",&N);
        while(~scanf("%s",&ch)){
            if(strlen(ch)==4) {
                scanf("%d",&num);
                pre.push_back(num);
                sta.push(num);
            }else{
                in.push_back(sta.top());
                sta.pop();
                if(in.size()==N) break;
            }
        }
        postorder(0,0,N-1);
        for(int i=0;i<N;i++)
            if(i!=N-1) printf("%d ",post[i]);
            else printf("%d",post[i]);
    
        system("pause");
        return 0;
    }
  • 相关阅读:
    20180604_Myeclipse下配置SVN报错问题 svn
    20180603_升级Win10后,远程连接桌面连接,出现身份验证错误!
    20180603_navicat 连接sqlserver提示要安装 sql server native client
    VB.net程序实现分页
    多线程Demo
    多线程Demo VB.net
    SQLServer数据库子结构
    SQLServer数据库常用命令
    传播路径图调查2013年初
    拾遗
  • 原文地址:https://www.cnblogs.com/littlepage/p/11671482.html
Copyright © 2020-2023  润新知