• PAT Advanced 1154 Vertex Coloring (25 分)


    A proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

    Now you are supposed to tell if a given coloring is a proper k-coloring.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 1), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N1) of the two ends of the edge.

    After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

    Output Specification:

    For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

    Sample Input:

    10 11
    8 7
    6 8
    4 5
    8 4
    8 1
    1 2
    1 4
    9 8
    9 1
    1 0
    2 4
    4
    0 1 0 1 4 1 0 1 3 0
    0 1 0 1 4 1 0 1 0 0
    8 1 0 1 4 1 0 5 3 0
    1 2 3 4 5 6 7 8 8 9
    

    Sample Output:

    4-coloring
    No
    6-coloring
    No



    #include <iostream>
    #include <unordered_set>
    #include <algorithm>
    using namespace std;
    
    int main()
    {
        int vertx_num,edge_num,x,y;
        cin>>vertx_num>>edge_num;
        pair<int,int> p[edge_num];
        for(int i=0;i<edge_num;i++)
            cin>>p[i].first>>p[i].second;
        int test;cin>>test;int color[vertx_num];
        while(test--){
            bool no=false;unordered_set<int> s;
            for(int i=0;i<vertx_num;i++){
                cin>>color[i];
                s.insert(color[i]);
            }
            for(int i=0;i<edge_num;i++){
                if(color[p[i].first]==color[p[i].second]){
                    cout<<"No"<<endl;
                    no=true;
                    break;
                }
            }
            if(!no) cout<<s.size()<<"-coloring"<<endl;
        }
        system("pause");
        return 0;
    }
  • 相关阅读:
    httpclient 发送 json数据,微信security.msgSecCheck,
    win10 输入法,添加美式键盘,调整顺序
    activiti与spring的集成
    spring 中实例化Bean的三种方式
    工作流activiti的HelloWorld
    工作流Activiti的前置准备工作。
    Eclipse中配置约束(DTD,XSD)
    微信开发中,本地缓存,不同步的问题
    微信开发中碰到的坑,json传值,前台遍历json对象,跨页面转值,navigate层级限制
    用pageInfo对List手工分页
  • 原文地址:https://www.cnblogs.com/littlepage/p/11616683.html
Copyright © 2020-2023  润新知