• 浙大数据结构课后习题 练习一 7-1 Maximum Subsequence Sum (25 分)


    Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    

    Sample Output:

    10 1 4



    #include <iostream>
    #include <vector>
    using namespace std;
    int main()
    {
        int T;
        cin>>T;int sum=0,tmp,max=-1;
        vector<int> vec;
        vector<int> res;
        vector<int> all;
        while(T--){
            cin>>tmp;
            all.push_back(tmp);
            vec.push_back(tmp);
            sum+=tmp;
            if(sum>max) {
                max=sum;
                res=vec;
            }
            if(sum<0){
                sum=0;
                vec.clear();
            }
        }
        if(max!=-1) cout<<max<<" "<<res[0]<<" "<<res[res.size()-1];
        else cout<<0<<" "<<all[0]<<" "<<all[all.size()-1];
        system("pause");
        return 0;
    }
  • 相关阅读:
    Spring笔记:常用xml标签和属性 山上下了雪
    Spring笔记:Hello World 山上下了雪
    Spring笔记:bean的自动装配 山上下了雪
    IntelliJ IDEA 2020.3.3 x64破解到2099年
    每日长进计划
    idea测试类中的测试方法没有运行按钮
    删除所有的phpfpm进程命令
    高质量编程
    单例模式也能玩出花
    宝塔Linux面板安装命令
  • 原文地址:https://www.cnblogs.com/littlepage/p/11374981.html
Copyright © 2020-2023  润新知