• PAT Advanced 1035 Password (20 分)


    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (≤), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    

    Sample Output 1:

    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    

    Sample Input 2:

    1
    team110 abcdefg332
    

    Sample Output 2:

    There is 1 account and no account is modified
    

    Sample Input 3:

    2
    team110 abcdefg222
    team220 abcdefg333
    

    Sample Output 3:

    There are 2 accounts and no account is modified
    #include<iostream>
    #include<vector>
    using namespace std;
    struct user{
        string id;
        string pw;
    };
    int main() {
        int T;
        cin>>T;
        user tmp;
        vector<user> vec;
        bool isConfused=false;
        for(int i=0;i<T;i++){
            isConfused=false;
            cin>>tmp.id>>tmp.pw;
            for(int i=0;i<tmp.pw.length();i++){
                switch(tmp.pw[i]){
                    case '1':
                        tmp.pw[i]='@';
                        isConfused=true;
                        break;
                    case '0':
                        tmp.pw[i]='%';
                        isConfused=true;
                        break;
                    case 'l':
                        tmp.pw[i]='L';
                        isConfused=true;
                        break;
                    case 'O':
                        tmp.pw[i]='o';
                        isConfused=true;
                        break;
                }
            }
            if(isConfused) vec.push_back(tmp);
        }
        if(vec.size()==0) {
            if(T==1) printf("There is 1 account and no account is modified");
            else printf("There are %d accounts and no account is modified",T);
            /**需要注意account和accounts是不一样的*/
        }
        else{
            cout<<vec.size()<<endl;
            for(int i=0;i<vec.size();i++){
                cout<<vec[i].id<<" "<<vec[i].pw<<endl;
            }
        }
        system("pause");
        return 0;
    }
  • 相关阅读:
    关于PHP程序员技术职业生涯规划
    让PHP7达到最高性能的几个Tips
    php-fpm解读-进程管理的三种模式 及 worker进程、master进程详解
    CGI、FastCGI和php-fpm概念和区别
    什么是PHP7中的孤儿进程与僵尸进程,加上守护进程
    PHP 信号管理知识整理汇总
    PHP多进程---fork多个子进程,父进程阻塞与非阻塞
    锁存器、触发器和寄存器
    FPGA基础之锁存器与触发器的设计
    从CMOS到触发器(二)
  • 原文地址:https://www.cnblogs.com/littlepage/p/11300848.html
Copyright © 2020-2023  润新知