• PAT Advanced 1058 A+B in Hogwarts (20 分)


    If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

    Input Specification:

    Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

    Output Specification:

    For each test case you should output the sum of A and B in one line, with the same format as the input.

    Sample Input:

    3.2.1 10.16.27
    

    Sample Output:

    14.1.28

    #include<iostream>
    using namespace std;
    struct money{
        int g;
        int s;
        int k;
    };
    int main() {
        money a,b,res;
        scanf("%d.%d.%d %d.%d.%d",&a.g,&a.s,&a.k,&b.g,&b.s,&b.k);
        res.g=a.g+b.g;
        res.s=a.s+b.s;
        res.k=a.k+b.k;
        if(res.k>28){
            res.k-=29;
            res.s++;
        }
        if(res.s>16){
            res.s-=17;
            res.g++;
        }
        cout<<res.g<<"."<<res.s<<"."<<res.k;
        system("pause");
        return 0;
    }
  • 相关阅读:
    括号匹配
    超级阶梯问题
    进制问题
    rwkj 1423
    next_permutation
    rwkj 1420
    uva-10392-因数分解
    uva-10305-水题-拓扑排序
    uva-10194-排序
    uva-10152-乌龟排序
  • 原文地址:https://www.cnblogs.com/littlepage/p/11296415.html
Copyright © 2020-2023  润新知