• POJ-2431 优先队列


    Expedition
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7575   Accepted: 2234

    Description

    A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

    To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

    The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

    Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

    Input

    * Line 1: A single integer, N 

    * Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

    * Line N+2: Two space-separated integers, L and P

    Output

    * Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

    Sample Input

    4
    4 4
    5 2
    11 5
    15 10
    25 10
    

    Sample Output

    2
    #include<iostream>
    #include<queue>
    #define MAX 10001
    using namespace std;
    
    int N, L, P;
    //int a[MAX], b[MAX];
    typedef struct {
        int a, b;
    }fuelstation;
    bool cmp(fuelstation x, fuelstation y){
        return x.a > y.a;
    }
    fuelstation fuel[MAX];
    
    void solve(){
        cin >> N;
        for (int i = 0; i < N; i++){
            //cin >> a[i] >> b[i];
            cin >> fuel[i].a >> fuel[i].b;
        }
        cin >> L >> P;
        fuel[N].a = 0; fuel[N].b = 0; N++;
    
        sort(fuel, fuel + N, cmp);
    
        priority_queue<int> que;
        int time = 0, pos = L, tank = P;
    
        for (int i = 0; i < N; i++){
            int d = pos - fuel[i].a;
            while (tank - d < 0){
                if (que.empty()){
                    cout << "-1" << endl;
                    return;
                }
                tank += que.top();
                que.pop();
                time++;
            }
            tank -= d;
            pos = fuel[i].a;
            que.push(fuel[i].b);
        }
        cout << time << endl;
    }
    
    int main()
    {
        solve();
        system("pause");
        return 0;
    }
    View Code
    世上无难事,只要肯登攀。
  • 相关阅读:
    《计算机图形学-基于3D图形开发技术》读书笔记
    【转】OpenGL和D3D 矩阵对比
    【转】D3D中详细拾取操作
    根据点坐标改变字体显示位置
    静态常量和常量在类中的初始化
    MFC单文档中使用D3D9
    单文档切换OpenGL视图
    超大地形的处理 (Terrain Visualization)【转自知乎】
    又出现这种问题。。。
    属性
  • 原文地址:https://www.cnblogs.com/littlehoom/p/4202878.html
Copyright © 2020-2023  润新知