• Saruman's Army


    Saruman's Army
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 4420   Accepted: 2285

    Description

    Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

    Input

    The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

    Output

    For each test case, print a single integer indicating the minimum number of palantirs needed.

    Sample Input

    0 3
    10 20 20
    10 7
    70 30 1 7 15 20 50
    -1 -1

    Sample Output

    2
    4
    #define _CRT_SECURE_NO_DEPRECATE
    #include<iostream>
    #include<stdio.h>
    #include<stdlib.h>
    #include<string.h>
    #include<algorithm>
    #define MAX 1001
    using namespace std;
    
    int troop[MAX];
    
    void solve(){
        int r, n, res;
        while (cin >> r >> n){
            if (r == -1 && n == -1)return;
            res = 0;
            for (int i = 0; i < n; i++)cin >> troop[i];
            sort(troop, troop + n);
            for (int i = 0, far; i < n;){
                far = troop[i];
                while (i < n&&troop[i] - far <= r)i++;
                res++; //cout << "round:" << res << endl;
                far = troop[i - 1];
                while (i < n&&troop[i] - far <= r)i++;
            }
            cout << res << endl;
        }
    }
    
    int main()
    {
        solve();
        //system("pause");
        return 0;
    }
    世上无难事,只要肯登攀。
  • 相关阅读:
    常用的电脑快捷键【转】
    win10关闭自动更新【转】
    JavaScript中双叹号(!!)作用【转】
    javascript中获取dom元素的高度和宽度【转】
    javascript的setTimeout()用法总结,js的setTimeout()方法【转】
    JavaScript sort() 方法使用【转】
    JavaScript slice() 方法使用【转】
    Ball CodeForces
    C. Trailing Loves (or L'oeufs?)
    C
  • 原文地址:https://www.cnblogs.com/littlehoom/p/4198723.html
Copyright © 2020-2023  润新知