题号:POJ 2386
题目:
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John's field, determine how many ponds he has.
Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
分析:题目给出一个地图,W代表水坑,.代表干地,要你求图中共有多少个大水坑(连在一起的小水坑算一个,周围的九个方位都算),差不多就是一个DFS的模板题,从找的第一个W出发,寻找周围有的‘W',找到就让它为’ .',不然会重复操作;
AC代码:
#include<iostream>
#include<cstdio>
#define N 125
using namespace std;
char a[N][N];
int row,col;
void dfs(int x,int y)
{
a[x][y]='.';
for (int dx=-1;dx<=1;dx++)
for (int dy=-1;dy<=1;dy++)
{
int nx=x+dx,ny=y+dy;
if (nx>=0&&nx<=row&&ny>=0&&ny<=col&&a[nx][ny]=='W')
dfs(nx,ny);
}
}
int main()
{
cin>> row>> col;
for (int i = 0; i <row; i++)
for (int j = 0; j <col; j++)
cin >>a[i][j];
int res = 0;
for(int i=0;i<row;i++)
for(int j=0;j<col;j++)
if (a[i][j] == 'W')//从有积水的地方开始dfs
{
dfs(i, j);
res++;
}
cout << res << endl;
return 0;
}