• Oil Deposits(油田)(DFS)


    题目:

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvCompworkswithonelargerectangularregionoflandatatime,andcreatesagridthatdivides the land into numerous square plots.

    It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

    A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit.

    Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

    Input

    The input file containsone or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 ≤ m ≤ 100 and 1 ≤ n ≤ 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the absence of oil, or ‘@’, representing an oil pocket. Output

    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

    Sample Input

    1 1

    *

    3 5

    *@*@*

    **@**

    *@*@*

    1 8

    @@****@*

    5 5

    ****@

    *@@*@

    *@**@

    @@@*@

    @@**@

    0 0

    Sample Output

    0 1 2 2

    题意:

    和迷宫的输入差不多,‘*’是墙,‘@’是油田,以一个油田为中心,如果它的东南西北一个各个角落,一共八个方向也有油田的话,这些油田就算作一个油田。

    分析:

    查找到‘@’的位置,找到一个,油田加1,对找到的‘@’的四周进行DFS查找,刚开始我以为和迷宫的做法差不多,我把查找过的地方用一个数组标记一下,后来测试结果不对,

    才发现在某一次存在题意中的相邻油田时,在主函数中会加1,而实际上这块油田我已经计算进去了,这样就重复了。正确的做法应该是把计算进去的那块油田变为‘*’,这样

    就不存在重复计算了!!!

    AC代码:

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    char a[102][102];
    int row,col;
    int dir[8][2]=
    {
        {1,0},
        {1,1},
        {1,-1},
        {0,-1},
        {0,1},
        {-1,0},
        {-1,1},
        {-1,-1}
    };
    using namespace std;
    void dfs(int i,int j)
    {
        a[i][j]='*';
        for (int k=0;k<8;k++)
        {
            int x=i+dir[k][0];
            int y=j+dir[k][1];
            if (x>=1&&x<=row&&y>=1&&y<=col&&a[x][y]=='@')
                dfs(x,y);
        }
        return ;
    }
    int main()
    {
        while ((cin>>row>>col)&&(row!=0||col!=0))
        {
            int c=0;
            getchar();
            for (int i=1;i<=row;i++)
                for (int j=1;j<=col;j++)
                cin>>a[i][j];
            for (int i=1;i<=row;i++)
                for (int j=1;j<=col;j++)
                if (a[i][j]=='@')
                {
                    dfs(i,j);
                    c++;
                }
            cout << c << endl;
        }
        return 0;
    }
  • 相关阅读:
    解决.Net 4.0 A potentially dangerous Request.Form value was detected from the client 异常
    解决背景在360极速模式下不显示的问题
    ASP怎么解除文件上传200kb限制
    mysql导入数据出错
    ECShop出现Strict Standards: Only variables should be passed by reference in的解决方法
    phpmyadmin导入sql数据的纠结
    Veket_Porteus_Puppy安装器by双心
    多系统的福音,bcdedit找回传统启动菜单。取消(恢复)Modern UI风格启动菜单~菜单~
    关于fbinst-ud区的几点看法
    高速公路坐标高程计算软件4.2版本发布
  • 原文地址:https://www.cnblogs.com/lisijie/p/7239839.html
Copyright © 2020-2023  润新知