• 2021“MINIEYE杯”中国大学生算法设计超级联赛(4)1001. Calculus(思维)


    Problem Description

    This summer, ZXyang became so tired when doing the problems of Multi-University contests. So he decided to attend the Unified National Graduate Entrance Examination. This day, he sees a problem of series.

    Let S(x) be a function with x as the independent variable. S(x) can be represented by the formula as follow.

    f(x)=∑i=1nfi(x)

    S(x)=∑j=1xf(j)

    fi(x) is a function with x as the independent variable. Furthermore. fi(x) belongs to the function set F.

    F={C,Cx,Csinx,Ccosx,Csinx,Ccosx,Cx,Cx}

    C is a constant integer ranging from 0 to 109.

    ZXyang wonders if S(x) is convergent. S(x) is convergent if and only if limx→∞S(x)=c, where c is a constant.

    Input

    The first line of input contains a single integer t (1≤t≤104) --- the number of test cases.

    The first and the only line of each test case contains a single string s (1≤|s|≤100), indicating the formula of f(x). Fraction is presented as a/b. Cx is presented as C^x. It's guaranteed that the constant C won't be left out when C=1. f(x) consists of functions from F connected with +.

    Output

    For each test case, print YES in one line if S(x) is a convergent sequence, or print NO in one line if not.

    Sample Input

    2
    1sinx+0cosx+3x+6/sinx
    0
    

    Sample Output

    NO
    YES
    

    签到题,这些级数都是不收敛的,因此必须每一项的系数都是0才可以。特别注意常数项的情况。至于代码可以先把每一项拆开判断。

    #include <bits/stdc++.h>
    using namespace std;
    int main() {
    	int t;
    	cin >> t;
    	while(t--) {
    		string s;
    		cin >> s;
    		int len = s.size();
    		int lst = 0;
    		vector<string> v;
    		for(int i = 0; i <= len; i++) {
    			if(i == len || s[i] == '+') {
    				v.push_back(s.substr(lst, i - lst));
    				lst = i + 1;
    			}
    		}
    		bool flag = 1;
    		for(auto x : v) {
    
    			int pos = x.find("/");
    			if(pos != x.npos) {
    				if(!(pos == 1 && x[0] == '0')) {
    					flag = 0;
    					break;
    				}
    				continue;
    			}
    
    			int pos1 = x.find("^");
    			if(pos1 != x.npos) {
    				if(!(pos1 == 1 && (x[0] == '0' || x[0] == '1'))) {
    					// cout << "fuck";
    					flag = 0;
    					break;
    				}
    				continue;
    			}
    			int pos2 = x.find("sin");
    			if(pos2 != x.npos) {
    				if(!(pos2 == 1 && x[0] == '0')) {
    					flag = 0;
    					break;
    				}
    				continue;
    			}
    			int pos3 = x.find("cos");
    			if(pos3 != x.npos) {
    				if(!(pos3 == 1 && x[0] == '0')) {
    					flag = 0;
    					break;
    				}
    				continue;
    			}
    			int pos4 = x.find("x");
    			if(pos4 != x.npos) {
    				if(!(pos4 == 1 && x[0] == '0')) {
    					flag = 0;
    					break;
    				}
    				continue;
    			}
    			if(x.size() > 1 || x[0] != '0') {
    				flag = 0;
    				break;
    			}
    		}
    		if(flag) puts("YES");
    		else puts("NO");
    	}
    	return 0;
    }
    
  • 相关阅读:
    对于对象的要求:高内聚、低耦合,这样容易拼装成为一个系统
    为什么要使用面向对象
    什么是对象:EVERYTHING IS OBJECT(万物皆对象)
    文件 I/O 问题
    如果可能的话,使用 PC-Lint、LogiScope 等工具进行代码审查
    把编译器的选择项设置为最严格状态
    尽量不要使用与具体硬件或软件环境关系密切的变量
    尽量使用标准库函数
    如果原有的代码质量比较好,尽量复用它
    不要设计面面俱到、非常灵活的数据结构
  • 原文地址:https://www.cnblogs.com/lipoicyclic/p/15076079.html
Copyright © 2020-2023  润新知