• POJ2955 Brackets (区间DP)


    We give the following inductive definition of a “regular brackets” sequence:

    • the empty sequence is a regular brackets sequence,
    • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
    • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
    • no other sequence is a regular brackets sequence

    For instance, all of the following character sequences are regular brackets sequences:

    (), [], (()), ()[], ()[()]

    while the following character sequences are not:

    (, ], )(, ([)], ([(]

    Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < imn, ai1ai2aim is a regular brackets sequence.

    Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

    Input

    The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

    Output

    For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

    Sample Input

    ((()))
    ()()()
    ([]])
    )[)(
    ([][][)
    end

    Sample Output

    6
    6
    4
    0
    6
    区间DP经典例题。因为括号是可以嵌套并列的,所以想到区间DP(才不是因为看到了标签..这个DP数组的含义比较好想到,dp[i][j]表示下标i~j的这一段字符串最多有多少个括号匹配了,按照区间DP的常见套路,第一层枚举区间长度,由于匹配最少需要两个括号,所以len从2开始;第二层枚举左端点,同时也可以根据左端点和长度确定右端点。这里先判断一步,如果s[i]和s[j]匹配了,那么dp[i][j]起码是dp[i+1][j-1]+2(为什么说是起码呢?因为考虑样例的()()()这个序列自然就明白了)
    然后找决策点,看看由两个分开的子区间能不能转移到当前并且使得答案更大。最后输出的就是dp[0][len-1]。
    #include <iostream>
    #include <cstring>
    #include <cmath>
    #include <cstdio>
    using namespace std;
    char s[105];
    int dp[105][105];
    bool check(int l,int r)
    {
        if(s[l]=='('&&s[r]==')')return true;
        if(s[l]=='['&&s[r]==']')return true;
        return false;
    }
    int main()
    {
        while(scanf("%s",s)&&s[0]!='e')
        {
            memset(dp,0,sizeof(dp));
            int len,i,j,k;
            for(len=2;len<=strlen(s);len++)
            {
                for(i=0;i+len-1<=strlen(s)-1;i++)
                {
                    int j=i+len-1;
                    if(check(i,j))
                    {
                        dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
                    }
                    for(k=i;k<=j-1;k++)
                    {
                        dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
                    }
                    
                }
            }
            cout<<dp[0][strlen(s)-1]<<endl;
        }
        return 0;
    }



  • 相关阅读:
    struts2 标签 前台遍历 字符串数组 String[]
    007-服务器域名&上传网站
    006-DOS命令
    005-OSI七层模型&IP地址
    004-编程语言发展史
    003-计量单位
    002-B/S架构&C/S架构
    001-计算机的组成
    1083. List Grades (25)
    1037. Magic Coupon (25)
  • 原文地址:https://www.cnblogs.com/lipoicyclic/p/12516612.html
Copyright © 2020-2023  润新知