Language:Default Lake Counting
Description Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John's field, determine how many ponds he has. Input * Line 1: Two space-separated integers: N and M * Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them. Output * Line 1: The number of ponds in Farmer John's field. Sample Input 10 12 W........WW. .WWW.....WWW ....WW...WW. .........WW. .........W.. ..W......W.. .W.W.....WW. W.W.W.....W. .W.W......W. ..W.......W. Sample Output 3 |
#include <iostream>
#include<stdio.h>using namespace std;
int ans=0;
int N,M;
char arr[101][101];
bool vis[101][101];
int dx[3]={-1,0,1};
int dy[3]={-1,0,1};
void dfs(int i,int j)
{
vis[i][j]=1;
for(int a=0;a<3;a++)
{
for(int b=0;b<3;b++)
{
if(i+dx[a]<0||i+dx[a]>=N)continue;
if(j+dy[b]<0||j+dy[b]>=M)continue;
if(!vis[i+dx[a]][j+dy[b]]&&arr[i+dx[a]][j+dy[b]]=='W')
{
dfs(i+dx[a],j+dy[b]);
}
}
}
}
int main()
{
//freopen("in.txt","r",stdin);
cin>>N>>M;
for(int i=0;i<N;i++)
{
for(int j=0;j<M;j++)
{
cin>>arr[i][j];
}
}
for(int i=0;i<N;i++)
{
for(int j=0;j<M;j++)
{
if(!vis[i][j]&&arr[i][j]=='W')
{
dfs(i,j);ans++;
}
}
}
cout<<ans<<endl;
return 0;
}