• poj 3623(贪心)


    Best Cow Line, Gold
    Time Limit: 5000MS Memory Limit: 65536K
    Total Submissions: 6038 Accepted: 2087

    Description

    FJ is about to take his N (1 ≤ N ≤ 30,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

    The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

    FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

    FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

    Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

    Input

    * Line 1: A single integer: N
    * Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

    Output

    The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

    Sample Input

    6
    A
    C
    D
    B
    C
    B

    Sample Output

    ABCBCD

    参考代码:

    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    int main()
    {
        //freopen("in.txt","r",stdin);
        int N;
        cin>>N;
        char in[N];
        char out[N+2];
        int i=0;char c;
        while(cin>>c){in[i++]=c;}
        in[i]='';
        int pos1=0;int pos2=strlen(in)-1;int pos=0;
        while(pos1<=pos2)
        {
        if(in[pos1]<in[pos2])out[pos++]=in[pos1++];
        else if(in[pos1]>in[pos2])out[pos++]=in[pos2--];
        else //如果in[pos1]==in[pos2]
        {
            int t1=pos1;int t2=pos2;
            while(in[t1]==in[t2]&&t1<=t2)
            {
                t1++;t2--;
            }
            if(in[t1]==in[t2])out[pos++]=in[pos1++];
            else if(in[t1]<in[t2])out[pos++]=in[pos1++];
            else out[pos++]=in[pos2--];
        }
        }
        out[pos]='';
        int cnt=0;
        while(out[cnt]!='')
        {
            cout<<out[cnt];cnt++;
            if(cnt%80==0)cout<<endl;
        }
        return 0;
    }



  • 相关阅读:
    从零搭建springboot+mybatis逆向工程
    基础SQL总结
    Map集合浅谈
    ArrayList、LinkedList与Vector的区别
    java多线程总结
    P4108 [HEOI2015]公约数数列
    P2168 [NOI2015] 荷马史诗
    正睿 2021 Noip 十连测 Day2
    CF772E Verifying Kingdom
    BZOJ1767 [CEOI2009] Harbingers
  • 原文地址:https://www.cnblogs.com/linruier/p/9485185.html
Copyright © 2020-2023  润新知