• 福尔摩斯的约会


    A1061 Dating (20)(20 分)

    Sherlock Holmes received a note with some strange strings: "Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm". It took him only a minute to figure out that those strange strings are actually referring to the coded time "Thursday 14:04" -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter 'D', representing the 4th day in a week; the second common character is the 5th capital letter 'E', representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is 's' at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

    Input Specification:

    Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

    Output Specification:

    For each test case, print the decoded time in one line, in the format "DAY HH:MM", where "DAY" is a 3-character abbreviation for the days in a week -- that is, "MON" for Monday, "TUE" for Tuesday, "WED" for Wednesday, "THU" for Thursday, "FRI" for Friday, "SAT" for Saturday, and "SUN" for Sunday. It is guaranteed that the result is unique for each case.

    Sample Input:

    3485djDkxh4hhGE 
    2984akDfkkkkggEdsb 
    s&hgsfdk 
    d&Hyscvnm
    

    Sample Output:

    THU 14:04
    
    #include <stdio.h>
    #include <string.h>
    int main() {
        char week[7][5] = {
            "MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN"
        };
        char str1[70], str2[70], str3[70], str4[70];
        gets(str1);
        gets(str2);
        gets(str3);
        gets(str4);
        int len1 = strlen(str1);
        int len2 = strlen(str2);
        int len3 = strlen(str3);
        int len4 = strlen(str4);
        int i;
        for(i = 0; i < len1 && i < len2; i++) {
            if(str1[i] == str2[i] && str1[i] >='A' && str1[i] <= 'G') {
                printf("%s ", week[str1[i] - 'A']);
                break;
            }
        }
        for(i++; i < len1 && i < len2; i++) {//接续前一个循环
            if(str1[i] == str2[i]) {
                if(str1[i] >= '0' && str1[i] <= '9') {
                    printf("%02d:", str1[i] - '0');
                    break;
                } else if(str1[i] >= 'A' && str1[i] <= 'N') {
                    printf("%02d:", str1[i] - 'A' + 10);
                    break;
                }
            }
        }
        for(i = 0; i < len3 && i < len4; i++) {
            if(str3[i] == str4[i]) {
                if((str3[i] >= 'A' && str3[i] <= 'Z') || (str3[i] >= 'a' && str3[i] <= 'z')) {
                    printf("%02d", i);
                    break;
                }
            }
        }
        return 0;
    }
    
  • 相关阅读:
    AFN的使用(待整理)
    [转]文件上传进度显示
    图片上传在线预览
    Mysql中文乱码,修改字符集
    struts2 实现自定义标签
    设置HTML和JSP页面不缓存的方法
    Spring framework3.2整合hibernate4.1报错:No Session found for current thread
    Java用SAX解析XML
    js操作Cookie
    php创建缩略图
  • 原文地址:https://www.cnblogs.com/lingr7/p/9452385.html
Copyright © 2020-2023  润新知