• POJ-3069 Saruman's Army


    Description

    Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

    Input

    The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

    Output

    For each test case, print a single integer indicating the minimum number of palantirs needed.

    Sample Input

    0 3
    10 20 20
    10 7
    70 30 1 7 15 20 50
    -1 -1

    Sample Output

    2
    4

    #include <iostream>
    #include <algorithm>
    using namespace std;
    
    int main(void)
    {
        int r, n, i, p;
        int point[300];
        
        while(cin >> r >> n && r != -1 && n != -1)  {
            for(i = 0; i < n; i++)
                cin >> point[i];
            
            sort(point, point+n);
            
            i = 0;
            int ans = 0;
            while(i < n)    {
                int s = point[i++];          //s是没有被覆盖的最左边的点
                
                while(point[i] <= s+r && i < n)
                    i++;
                
                p = point[i-1];         //p为被标记的点
                
                while(point[i] <= p+r && i < n)
                    i++;
                
                ans++;
                
                
                
            }
            
            
            cout << ans << endl;
        }
        
        
        return 0;
    }
    
  • 相关阅读:
    Address already in use: JVM_Bind:80 异常的解决办法
    Spring(转载二)
    Spring(转载一)
    mybatis(二)
    mybatis(一)
    存储过程(二)
    存储过程(一)
    web过滤器
    请求转发和请求重定向
    JavaWeb(二)
  • 原文地址:https://www.cnblogs.com/limyel/p/7198906.html
Copyright © 2020-2023  润新知