• HDU-1008 Elevator


    Description

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input

    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

    Output

    Print the total time on a single line for each test case. 

    Sample Input

    1 2

    3 2 3 1

    0

    Sample Output

    17

    41


    水,注意连续几个数都是同一层楼时,停留时间都要加的

    #include <iostream>
    using namespace std;
    
    int main(void)
    {
        int n;
        
        while(cin >> n && n)
        {
            int a[1001];
            int time = 0;
            
            a[0] = 0;
            for(int i = 1; i <= n; i++)
            {
                cin >> a[i];
            }
            for(int i = 1; i <= n; i++)
            {
                time += 5;
                if(a[i] == a[i-1])
                    continue;
                else
                {
                    if(a[i]-a[i-1] > 0)
                        time += (a[i]-a[i-1])*6;
                    else if(a[i]-a[i-1] < 0)
                        time += abs((a[i]-a[i-1]))*4;
                }
            }
            cout << time << endl;
        }
        return 0;
    }
    
  • 相关阅读:
    web Function函数
    web语言发展史
    用户正则
    字符串替换
    css单位
    JavaScript DOM&BOM
    css颜色的设置
    pseudo-class与pseudo-element的不同点与相同点
    对css语法中position值的理解
    API
  • 原文地址:https://www.cnblogs.com/limyel/p/6675751.html
Copyright © 2020-2023  润新知