• HDU-1004 Let the Balloon Rise


    Description

    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.

    Input

    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.

    Output

    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

    Sample Input

    5

    green red blue red red

    3

    pink orange pink

    0

    Sample Output

    red

    pink


    水,用一个结构体来存储颜色种类及数量,当输入的颜色还没有过时,在结构体数组中存入,如果有,则数量加一,最后按照结构体中的数量大小进行排序即可。

    #include <iostream>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    
    struct color
    {
        char str[20];
        int num;
    }s[101];
    int k = 0;
    
    int main(void)
    {
        int t;
        void func(color *, char *);
        s[0] = {'', 0};
        bool sort_func(color a, color b);
        
        while(cin >> t && t)
        {
            k = 0;
            char inp[20];
            int i;
            
            for(i = 0; i < t; i++)
            {
                cin >> inp;
                func(s, inp);
            }
            sort(s, s+k, sort_func);
            cout << s[0].str << endl;
        }
            
        
        
        return 0;
    }
    
    
    bool sort_func(color a, color b)
    {
        return a.num > b.num;
    }
    
    
    void func(color *a, char *b)
    {
        for(int j = 0; j <= k; j++)
        {
            if(!strcmp((*(a+j)).str, b))
            {
                a[j].num++;
                return;
            }
        }
        strcpy(a[k].str, b);
        a[k++].num = 1;
        
        return;
    }
    
  • 相关阅读:
    矩阵树定理
    随机乱搞算法
    数学
    BZOJ——3412: [Usaco2009 Dec]Music Notes乐谱
    BZOJ—— 3402: [Usaco2009 Open]Hide and Seek 捉迷藏
    洛谷—— P2884 [USACO07MAR]每月的费用Monthly Expense
    洛谷—— P2417 课程
    洛谷—— P1577 切绳子
    COGS 2598. 美丽的感觉
    10.23 模拟赛
  • 原文地址:https://www.cnblogs.com/limyel/p/6671336.html
Copyright © 2020-2023  润新知