• Big Number HDU


    Big Number

    Problem Description
    As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.
    To make the problem easier, I promise that B will be smaller than 100000.
    Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
     
    Input
    The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
     
    Output
    For each test case, you have to ouput the result of A mod B.
     
    Sample Input
    2 3 12 7 152455856554521 3250
     
    Sample Output
    2 5 1521
     
    Author
    Ignatius.L
     
    题意:
    给出正整数 A 和 B,求 A mod B。
     
    思路:
    模拟除法运算即可。
     
    例:
     
     
     
    代码:
    #include <set>
    #include <map>
    #include <list>
    #include <stack>
    #include <queue>
    #include <deque>
    #include <cmath>
    #include <string>
    #include <vector>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #include <sstream>
    #include <iostream>
    #include <algorithm>
    #include <unordered_map>
    #define INF 0x3f3f3f3f
    #define ll long long
    #define ull unsigned long long
    #define fcio ios::sync_with_stdio(false); cin.tie(0); cout.tie(0)
    using namespace std;
    
    int main()
    {
        string a;
        int b;
        while(cin>>a>>b)
        {
            int t=0;
            for(int i=0;i<a.size();i++)
            {
                t=t*10+a[i]-'0';
                t=t%b;
            }
            cout<<t<<endl;
        }
    }
     
  • 相关阅读:
    java线程读取文件,可以同时读写 202006031002
    JS,JQuery bug202005282020
    js,jquery缩小加载的图片202005131907
    spring boot/spring cloud + mybatis + mysql bug 20200513
    html2020042901,table元素之间的间距
    ie8-ie11浏览器bug2020042801
    css的bug2020042801
    xml读取解析bug20200423
    Poi读取word(doc)文档的文本或图片
    NOI2020专题
  • 原文地址:https://www.cnblogs.com/lihahahahaji/p/13396827.html
Copyright © 2020-2023  润新知