• POJ 1068 Parencodings


    Parencodings
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 19283   Accepted: 11629

    Description

    Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
    q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
    q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

    Following is an example of the above encodings: 
    	S		(((()()())))
    
    	P-sequence	    4 5 6666
    
    	W-sequence	    1 1 1456
    
    

    Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

    Input

    The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

    Output

    The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

    Sample Input

    2
    6
    4 5 6 6 6 6
    9 
    4 6 6 6 6 8 9 9 9
    

    Sample Output

    1 1 1 4 5 6
    1 1 2 4 5 1 1 3 9

    水题>>>>>>>>>>




    AC代码例如以下:

    #include<iostream>
    using namespace std;
    int main()
    {
        int t,n;
        int i,j;
        int b[30],c[31];
        char a[30];
        cin>>t;
        while(t--)
        {
            cin>>n;
            for(i=1,b[0]=0;i<=n;i++)
                {
                    cin>>b[i];
                    c[i]=b[i]-b[i-1];
                }
            int tt=0;
            for(i=1;i<=n;i++)//生成匹配括号
            {
                for(j=1;j<=c[i];j++)
                    a[tt++]='(';
                a[tt++]=')';
            }
            for(i=0;i<tt;i++)
                if(a[i]==')')
                b[i]=1;
                else b[i]=-1;
            int sum,ans;
            for(i=0;i<tt;i++)
            {
                if(b[i]==1)
                {
                   ans=0;sum=0;
                   for(j=i;j>=0;j--)
                   {
                       sum+=b[j];
                       ans++;
                       if(sum==0)
                        {
                            if(i!=tt-1)
                            cout<<ans/2<<" ";
                            else cout<<ans/2;
                            break;
                        }
                   }
                }
    
            }
            cout<<endl;
        }
        return 0;
    }
    



  • 相关阅读:
    EM and GMM(Code)
    EM and GMM(Theory)
    安装Sphere v2.7 遇到的问题
    pyqt的 .ui 转换为 .py 后的操作注意事项
    SVM入门(一)
    关于范数的理解
    快速排序的C语言实现
    QT编程环境搭建
    flex布局左边固定,右边自适应,右边内容超出会影响布局
    未知宽高的div怎么垂直水平居中
  • 原文地址:https://www.cnblogs.com/liguangsunls/p/6851570.html
Copyright © 2020-2023  润新知