• POJ 3259:Wormholes bellman_ford判定负环


    Wormholes
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 37906   Accepted: 13954

    Description

    While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

    As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

    To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

    Input

    Line 1: A single integer, FF farm descriptions follow. 
    Line 1 of each farm: Three space-separated integers respectively: NM, and W 
    Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
    Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

    Output

    Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

    Sample Input

    2
    3 3 1
    1 2 2
    1 3 4
    2 3 1
    3 1 3
    3 2 1
    1 2 3
    2 3 4
    3 1 8

    Sample Output

    NO
    YES

    Hint

    For farm 1, FJ cannot travel back in time. 
    For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

    正常的path是双向的,有一定的消耗时间。虫洞是单向的,能够让时间倒流一定时间。问FJ能否找到一条路径,能够遇见之前的那个自己。

    说白了就是找负环。

    Bellman_ford模板题,用来对每一条边都进行松弛,然后看最后结果是否依然能够松弛。如果还能松弛,说明有负环;如果不能松弛了,就是没有负环。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    struct E{
    	int s;
    	int e;
    	int l;
    }edge[5205];
    
    int N,M,W,edge_num;
    int dis[505];
    
    void addedge(int start,int end,int len)
    {
    	edge_num++;
    
    	edge[edge_num].s=start;
    	edge[edge_num].e=end;
    	edge[edge_num].l=len;
    }
    
    bool bellman_ford()
    {
    	int i,j;
    	for(i=1;i<=N-1;i++)
    	{
    		int flag=0;
    		for(j=1;j<=edge_num;j++)
    		{
    			if(dis[edge[j].e]>dis[edge[j].s]+edge[j].l)
    			{
    				flag=1;
    				dis[edge[j].e]=dis[edge[j].s]+edge[j].l;
    			}
    		}
    		if(flag==0)
    			break;
    	}
    	for(j=1;j<=edge_num;j++)
    	{
    		if(dis[edge[j].e]>dis[edge[j].s]+edge[j].l)
    		{
    			return true;
    		}
    	}
    	return false;
    }
    
    int main()
    {
    	int i,start,end,len;
    	int Test;
    	cin>>Test;
    
    	while(Test--)
    	{
    		edge_num=0;
    		memset(dis,0,sizeof(dis));
    
    		cin>>N>>M>>W;
    
    		for(i=1;i<=M;i++)
    		{
    			cin>>start>>end>>len;
    
    			addedge(start,end,len);
    			addedge(end,start,len);
    		}
    		for(i=1;i<=W;i++)
    		{
    			cin>>start>>end>>len;
    
    			addedge(start,end,-len);
    		}
    		if(bellman_ford())
    		{
    			cout<<"YES"<<endl;
    		}
    		else
    		{
    			cout<<"NO"<<endl;
    		}
    	}
    	return 0;
    }


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Atitit.android js 的键盘按键检测Back键Home键和Menu键事件
    Atitit  OOCSS vs bem
    Atitit.js模块化 atiImport 的新特性javascript import
    Atitit.css 规范 bem 项目中 CSS 的组织和管理
    Atitit.eclipse git使用
    Atitit jOrgChart的使用  组织架构图css html
    Atitit.java相比c#.net的优点 优缺点  v2 q330
    Atitit.判断元素是否显示隐藏在父元素 overflow
    Atitit.获得向上向下左的右的邻居的方法 软键盘的设计..
    Atitit..css的体系结构
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4928109.html
Copyright © 2020-2023  润新知