• POJ 3061:Subsequence 查找连续的几个数,使得这几个数的和大于给定的S


    Subsequence
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 10172   Accepted: 4160

    Description

    A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

    Input

    The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

    Output

    For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

    Sample Input

    2
    10 15
    5 1 3 5 10 7 4 9 2 8
    5 11
    1 2 3 4 5

    Sample Output

    2
    3

    题意是给出一个序列,要求从这个序列中找出几个连续的数,使得这些数的和大于给定的S,求这个数的最小值。

    和51nod上面的建设国家很像,都是建立一个队列,然后不断查找。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    long long n,s,a[1000005];
    
    int main()
    {	
    	//freopen("i.txt","r",stdin);
    	//freopen("o.txt","w",stdout);
    
    	int test,i,ans,start;
    	long long sum;
    	scanf("%d",&test);
    
    	while(test--)
    	{
    		scanf("%lld%lld",&n,&s);
    		for(i=1;i<=n;i++)
    		{
    			scanf("%lld",a+i);
    		}
    		ans=n+1;
    		a[0]=0;
    		sum=0;
    		start=1;
    		for(i=1;i<=n;i++)
    		{
    			sum += a[i];
    			while(sum>s)
    			{
    				sum = sum - a[start];
    				start++;
    			}
    		   if(sum+a[start-1]>s && i-(start-1)+1<ans)
    		   {
    			   ans=i-(start-1)+1;
    		   }
    		}
    		if(ans == n+1)
    		{
    			cout<<0<<endl;
    		}
    		else
    		{
    			cout<<ans<<endl;
    		}
    	}
    	//system("pause");
    	return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    模块
    迭代器,生成器
    内置函数
    匿名函数,三元表达式,列表推导式,字典生成式
    递归
    闭包函数,装饰器
    名称空间与作用域
    《数据结构与算法之6 扑克牌洗牌算法》
    《java学习笔记》
    Building Machine Learning Systems with Python 2
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4899535.html
Copyright © 2020-2023  润新知